gump-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Leo Simons <m...@leosimons.com>
Subject Re: derby-split-2
Date Wed, 13 Jul 2005 10:01:11 GMT
Stefan Bodewig wrote:
> On Tue, 12 Jul 2005, Andrew McIntyre <mcintyre.a@gmail.com> wrote:
>>Sorry for the delay here...
> 
> I've been meaning to look into it myself but never found the time,
> sorry.
> 
>>However, the classpath reported by Gump doesn't appear to have any
>>JDK 1.4 classes on it, besides tools.jar. Also, I had a script which
>>emulates the Derby build in Gump by building with just one JDK on
>>the classpath for each split, and this script still compiles Derby
>>successfully. Is it possible that a change to Gump (or Ant) was made
>>that is causing JDK 1.4 (or higher) classes to appear on the
>>compilation classpath before the JDK 1.3 classes which are needed
>>for this compile?
> 
> IIRC it started to fail after the migration from brutus to vmgump, so
> maybe it really is more of an installation issue.

Hmmm.

> Leo, where did you get the rt.jar that is being used as 1.3 runtime?

Didn't remember, but I just checked, from
http://wiki.apache.org/gump/VmgumpConfig:

TODO: figure out which packages of the below on brutus is needed

lrwxrwxrwx   1 root root    35 Oct  6  2004 ant ->
/opt/__versions__/apache-ant-1.6.2/
lrwxrwxrwx   1 root root    31 Jan  7 11:57 cocoon ->
/opt/__versions__/cocoon-trunk/
lrwxrwxrwx   1 root root    32 Jan  7 11:57 forrest ->
/opt/__versions__/forrest-trunk/
lrwxrwxrwx   1 root root    29 Jan 24 23:47 jdk1.3 ->
/opt/__versions__/jdk1.3.1_14
lrwxrwxrwx   1 root root    27 Oct  6  2004 jdk1.5 ->
/opt/__versions__/jdk1.5.0/
lrwxrwxrwx   1 root root    31 Oct  6  2004 jetty ->
/opt/__versions__/jetty-4.2.21/
lrwxrwxrwx   1 root root    23 Oct 12  2004 kaffe -> /opt/__versions__/kaffe
lrwxrwxrwx   1 root root    29 Oct  6  2004 loader ->
/opt/__versions__/loader-1.0/
lrwxrwxrwx   1 root root    49 Oct  6  2004 mysql ->
/opt/__versions__/mysql-connector-java-3.0.15-ga/
lrwxrwxrwx   1 root root    31 Oct  6  2004 rdflib ->
/opt/__versions__/rdflib-2.0.3/
lrwxrwxrwx   1 root root    30 Oct  6  2004 servlet-api ->
/opt/__versions__/servlet-2.4/
lrwxrwxrwx   1 root root    32 Oct  9  2004 webware ->
/opt/__versions__/Webware-0.8.1/

the "TODO" means I didn't think about it a whole lot and/or gave up.
Further down it says

# update /usr/local/gump/packages/java-runtime-1.3 to have working symlinks

gump@vmgump:/usr/local/gump/packages/java-runtime-1.3$ rm LICENSE
gump@vmgump:/usr/local/gump/packages/java-runtime-1.3$ rm rt.jar
gump@vmgump:/usr/local/gump/packages/java-runtime-1.3$ ln -s
/opt/jdk1.4/LICENSE
gump@vmgump:/usr/local/gump/packages/java-runtime-1.3$ ln -s
/opt/jdk1.4/jre/lib/rt.jar

which obviously means that's the rt.jar from the 1.4 jre that I linked
to, probably because I couldn't figure out some build failure. We don't
have jdk 1.3 on vmgump at the moment I think. Everything on the
classpath is jdk 1.4.

> Is it the one from brutus?  Or maybe it is the jikes configuration?  I
> vaguely recall we've been running our own version of Jikes on brutus
> while the one on vmgump is a stock debian installed one.

I know I didn't install jikes. Nothing mentioned about it on
http://wiki.apache.org/gump/VmgumpConfig. If we had a custom jikes on
brutus it wasn't in /opt.

What should happen now? Regardless of what you change, please update the
wiki page :-)

You may have noticed I'm working on some sane management of installed
packages for gump3. Will make sure that this kind of thing is a lot
easier to debug than it is now.

cheers!

Leo

---------------------------------------------------------------------
To unsubscribe, e-mail: general-unsubscribe@gump.apache.org
For additional commands, e-mail: general-help@gump.apache.org


Mime
View raw message