gump-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <bode...@apache.org>
Subject Re: sync has problems with symlinks
Date Wed, 09 Feb 2005 07:52:02 GMT
On Tue, 8 Feb 2005, Dalibor Topic <robilad@kaffe.org> wrote:

> I have seen it but have't looked into it yet. I'm not sure from your
> description whether you think it's a bug in Kaffe, Gump, Python or
> Ant :)
> 
> Could you elaborate? 

I'll try, but right now I'm not exactly sure what't going on.  It
probably is a combination of a dumb (err, "less than optimal") way[1] to
test symlink handling in Ant, a bug in Kaffe and a bug in our own
Python script that syncs the workspace with the checked out CVS copy.

Step by step ...

(1) Ant creates a symlink inside its source tree in one of its tests.

(2) This symlink should get removed in the tearDown method of the
corresponding tests and that seems to fail on Kaffe.  To validate
this, I'll remove the ant working copy again and watch the test-ant
build on the next Kaffe run closely.  I'll also add some diagnostic
output to Ant's test itself.

(3) When our sync script runs, it treats the the symlink as a
directory and removal fails.  I think it should get fixed to deal with
symlinks properly.

Cheers

        Stefan

Footnotes: 
[1]  commited by me, so I'm free to admit it is dumb


---------------------------------------------------------------------
To unsubscribe, e-mail: general-unsubscribe@gump.apache.org
For additional commands, e-mail: general-help@gump.apache.org


Mime
View raw message