gump-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <bode...@apache.org>
Subject Re: cvs commit: gump/project groovy.xml
Date Wed, 08 Dec 2004 07:21:50 GMT
On 7 Dec 2004, <antonio@apache.org> wrote:

>   Better groovy definition

Thanks, a simple copy-paste leftover.

>   + use asm 1.4.3 instead of current CVS version (2.0)

I don't like this change, sorry.  The latest stable release of ASM is
1.5.1 and I really wouldn't want to go to any older release at all.
ASM 1.4.3 is here since hivemind needs groovy to build and uses
packaged-groovy which doesn't work with ASM 1.5.1.

The groovy project in Gump should serve as a reminder for the groovy
project that it currently doesn't build against the latest versions of
its dependencies (not even ASM 1.5.x).

If groovy said ASM 2.x is still too unstable to follow, I'd be willing
to introduce asm-1.x based on the ASM_1_5_1_PATCHES branch in CVS, for
example.

Building groovy against the versions it declares itself is rather
pointless in a Gump context and we wouldn't need to build it at all.

Stefan

---------------------------------------------------------------------
To unsubscribe, e-mail: general-unsubscribe@gump.apache.org
For additional commands, e-mail: general-help@gump.apache.org


Mime
View raw message