gump-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Adam R. B. Jack" <aj...@apache.org>
Subject Re: Problem running Apache Gump [brutus-test]
Date Fri, 03 Dec 2004 22:55:52 GMT
>   File "/usr/local/gump/test/gump/python/gump/core/model/project.py", line
577, in complete
>     self.addJVMArgs(self.getDomChild("ant"))
>   File "/usr/local/gump/test/gump/python/gump/core/model/project.py", line
639, in addJVMArgs
>     for jvmarg in domChild.getDomChildIterator('jvmarg'):
> AttributeError: Element instance has no attribute 'getDomChildIterator'
> Process Exit Code : 1

I ran this script (simply a load and preview) in order to ensure the bug was
still in the current code.

[gump@brutus] /usr/local/gump/test/gump $ python bin/preview.py -w
metadata/brutus.xml ant

It was. So I entered this fix.

    URL: http://svn.apache.org/viewcvs?view=rev&rev=109732
    Log:
    domChild is a Pure XML DOM Element, not a Gump Model Object.
    Since the latter is bound to a DOM Element we have helper methods
    that allow access to DOM sub-elements, but when we are using
    pure DOM object we need to use the shared functions.
    Modified:
       gump/trunk/python/gump/core/model/project.py

I've no idea if Stefan's original issue (what he went in to fix) was
resolved. Just getting my feet wet again...

regards,

Adam


---------------------------------------------------------------------
To unsubscribe, e-mail: general-unsubscribe@gump.apache.org
For additional commands, e-mail: general-help@gump.apache.org


Mime
View raw message