gump-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Adam Jack" <aj...@mric.coop>
Subject ws-jaxme failure on Gump
Date Wed, 06 Oct 2004 18:34:16 GMT
I took a look at the ws-jaxme configuration, and its Ant scripts. As far as
I followed it, I was wrong about this being a simple <work or <depend
problem. I wonder if it is a "clean environment" problem.

Looking at the build output:


http://brutus.apache.org/gump/public/ws-jaxme/ws-jaxme/gump_work/build_ws-jaxme_ws-jaxme.html
which gives...JM.precompile:

BUILD FAILED
/usr/local/gump/public/workspace/ws-jaxme/ant/jm.xml:60:
java.lang.ClassNotFoundException:
org.apache.ws.jaxme.generator.sg.AttributeSGIt seems that this (below) is
failing to find the (above) class:    <target name="JM.precompile"
depends="dirs,JS.all,XS.all,JS.taskdef">        <chainGenerator
destDir="${build.jm.src}">            <classpath>
<pathelement location="${src.jm}"/>            </classpath>
<chain
controllerInterfaceName="org.apache.ws.jaxme.generator.sg.AttributeSG"
chainInterfaceName="org.apache.ws.jaxme.generator.sg.AttributeSGChain"
proxyClassName="org.apache.ws.jaxme.generator.sg.impl.AttributeSGChainImpl"
implementationClassName="org.apache.ws.jaxme.generator.sg.impl.AttributeSGIm
pl"/>I do not know the purpose of this aspect of the build, but it seems (to
me) to be attempting to load a class that ought be built by JM.compile (a
task dependent upon this JM.precompile.)As such, could it be as simple as
(in a clean environment) the class being reference has yet to be
compiled?regardsAdam


---------------------------------------------------------------------
To unsubscribe, e-mail: general-unsubscribe@gump.apache.org
For additional commands, e-mail: general-help@gump.apache.org


Mime
View raw message