gump-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brett Porter <brett.por...@gmail.com>
Subject Re: Unit tests in Maven builds on Gump
Date Fri, 30 Jul 2004 04:02:18 GMT
I remember fixing a bug (although I think it was in unrelated goals)
in the test plugin that didn't put junit on the classpath when the
tests are forked.

You can try upgrading to the latest test plugin (or Maven 1.0) to see
if the bug was fixed. If not, try not forking the tests (this might
cause other classloader issues though). Or, you can add junit to the
dependencies (no harm in this).

Sorry, won't have time to look any closer for about 3 weeks as I'm on holidays.

Cheers,
Brett

On Thu, 29 Jul 2004 12:21:09 -0600, Adam R. B. Jack <ajack@trysybase.com> wrote:
> Brett (et al)
> 
> Dims had set up the <maven goal for Geronimo in Gump to be 'default', which
> builds a jar and does some unit tests. These tests have been failing (see
> below) due to the abscense of junit framework in the CLASSPATH. Now Gump is
> told to add junit, and (again, see below) it thinks it does. Can anybody
> explain what might be occuring?
> 
> Note: Until the next run comes along (and maybe changes things, 'cos I set
> the goal to be 'jar' for now) there is information at:
> 
> http://brutus.apache.org/gump/public/incubator-geronimo/incubator-geronimo/index.html
>

---------------------------------------------------------------------
To unsubscribe, e-mail: general-unsubscribe@gump.apache.org
For additional commands, e-mail: general-help@gump.apache.org


Mime
View raw message