gump-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Adam R. B. Jack" <aj...@trysybase.com>
Subject Re: JDK 1.5
Date Fri, 02 Jul 2004 15:00:11 GMT
Thanks, but our goal is to work completely in JDK1.5, so the task is to
either tighten our environment (to make JDK 1.4 simply "not available" to
the JDK 1.5 run) or to be more explicit/careful in Gump code (and bootstrap
scripts). I suspect the latter has the better long-term mileage, but I don't
know the best approach (for launching JDK compiler, and/or for Ant).

[We've had a need to have tools.jar on the CLASSPATH, so Ant can find a
compiler, which kinda goes against the purpose of Gump, and it setting
CLASSPATH. This is a JIRA entry I'd like to close.]

FWIIW: I'm facing similar w/ moving to Python 2.3 (and on some platforms I
need to check for 'python2.3' executable prior to 'python'). This is easier
since the scripts are more in my direct control.

regards,

Adam
----- Original Message ----- 
From: "Antoine Levy-Lambert" <antoine@gmx.de>
To: "Gump code and data" <general@gump.apache.org>
Sent: Friday, July 02, 2004 8:34 AM
Subject: Re: JDK 1.5


> Hi Adam,
>
> a quick Google search concerning this problem brought me to this link :
>
http://forum.java.sun.com/thread.jsp?thread=522017&forum=316&message=2500873
> What I understand, is that the problem means that we are trying to run
> under JDK 1.4 some code compiled under JDK 1.5.
> These options of javac : -source 1.5 -target jsr14 according to the
> article, allow to compile under jdk1.5 and to run under jdk1.4.
>
> Cheers,
> Antoine
>
> Adam R. B. Jack wrote:
>
> >The CleanUp branch is getting pretty darn close to matching the CVS HEAD
> >Gump again (the odd 'didn't expand @@DATE@@ somewhere obscure' kinda bug
> >might exist, but not in the first  projects, or so this seems to show:
> >http://gump.try.sybase.com/buildLog.html).
> >
> >However, we get this w/ CleanUp running on JDK1.5:
> >
> >
>
>http://brutus.apache.org/gump/jdk15/xml-crimson/xml-crimson/gump_work/build
_xml-crimson_xml-crimson.html#Output
> >
> >Exception in thread "main" java.lang.UnsupportedClassVersionError:
> >org/apache/tools/ant/Main (Unsupported major.minor version 49.0)
> >
> >I suspect that this means that (1) the JDK 1.5 compiler was found/used by
> >bootstrap-ant and and (2) the JDK 1.4 compiler was found/used by Ant and
> >does not grok JDK 1.5 classes. Just a guess.
> >
> >Any thoughts on how we tighten things up in an environment where we have
> >multiple compilers/JDKs installed? Can we get Ant to (tersely) tell us
which
> >compiler it has found and is using? Ought we try to tell Ant?
> >
> >The story this tells, is confused (at best):
> >
> >    http://brutus.apache.org/gump/jdk15/environment.html#Annotations
> >
>
>http://brutus.apache.org/gump/jdk15/environment.html#Tail+of+CheckEnvironme
nt+%3A+check_java_compiler
> >
> >Thanks in advance.
> >
> >regards,
> >
> >Adam
> >
> >
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: general-unsubscribe@gump.apache.org
> For additional commands, e-mail: general-help@gump.apache.org
>


---------------------------------------------------------------------
To unsubscribe, e-mail: general-unsubscribe@gump.apache.org
For additional commands, e-mail: general-help@gump.apache.org


Mime
View raw message