gump-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <bode...@apache.org>
Subject Re: Failures in xml-security
Date Mon, 01 Mar 2004 13:12:55 GMT
On Mon, 01 Mar 2004, Stefan Bodewig <bodewig@apache.org> wrote:
> On Mon, 01 Mar 2004, Berin Lautenbach <berin@wingsofhermes.org>
> wrote:
> 
>> Could someone check if the bouncycastle JCE has been installed on
>> lsd?
> 
> Yes, version 1.1.6.  This may be too old for xml-security's needs.
> I'll look into upgrading it just now.

Hmm, we've been using bouncycastle's cleanroom JCE for 1.3, actually.

If I do so for the latest version, I get a different type of error
message 

    [junit] org.apache.xml.security.encryption.XMLEncryptionException: Padding: ISO10126PADDING
not implemented
    [junit] Original Exception was javax.crypto.NoSuchPaddingException: Padding: ISO10126PADDING
not implemented
    [junit] 	at org.apache.xml.security.encryption.XMLCipher.getInstance(XMLCipher.java:285)

but it looks as if bouncycastle doesn't get used at all.

If I only use the provider jar and nothing else, I again get another
error (something about not being able to find provider "BC" or not
being able to verify it).

To me it looks as if we'd have to install things to use bouncycastle
with JDK 1.4 anyway, at least the unrestricted policy file has to be
installed.  I'd be glad if anybody with a better JCE background than I
have could help out here.

Stefan

---------------------------------------------------------------------
To unsubscribe, e-mail: general-unsubscribe@gump.apache.org
For additional commands, e-mail: general-help@gump.apache.org


Mime
View raw message