gump-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <bode...@apache.org>
Subject Re: JRE 1.4 endorsed mechanism
Date Mon, 16 Feb 2004 08:09:09 GMT
On Sun, 15 Feb 2004, Berin Lautenbach <berin@wingsofhermes.org> wrote:

> The xml-security library requires that xalan be installed in
> JDK_HOME/jre/lib/endorsed to override the old version that comes
> with JDK 1.4.

With Xerces-J we are going even further, we put the CVS HEAD jar onto
the bootclasspath so it gets used instead of Crimson.  This should be
possible with Xalan as well, and to me it even looks as if we'd use
the same mechanism (type="boot" on the <jar> element).

> Looking at the output from the last gump run for security, it would
> appear that the old library that comes with 1.4 is being used :

Seems build.clonevm is becoming a FAQ 8-)

The bootclasspath trick is not working since xml-security's <junit>
task runs in a different Java VM by using fork="true".  Ant's CVS HEAD
uses a new Java system property to ensure that the forked VM uses the
same bootclasspath as the one running Ant.

I'll enable that property for xml-security in a few minutes.

Cheers

        Stefan
-- 
http://stefanbodewig.blogger.de/

Mime
View raw message