gump-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Adam R. B. Jack" <aj...@trysybase.com>
Subject Re: http://gump.dotnot.org/todos.html
Date Tue, 21 Oct 2003 15:52:09 GMT
Thanks Nicola, it is good to have another pair of eyes over this data.

> (1)
> http://gump.dotnot.org/jakarta-poi/jakarta-poi.html
> http://gump.dotnot.org/spice-pe/spice-xinvoke-pe.html
>
> Failing because artifacts are not there, but IIRC default Gump does not
> fail on this. In any case, failing on missing artifacts *is* correct.

Yeah I decided that this was needed. No point dependee projects being marked
as 'failed due to pre-requisites' but the "cause" project be marked as good.
As such, all output artifacts are checked after a build, and the project
marked as fail [and nagged upon] if missing. If good, the artifacts are
published to the repository (which seems to be growing...
http://gump.dotnot.org/repository/ and good fodder for Ruper2 :-)

[If Andy doesn't get to POI soon (I mailed the list) I might try and figure
out which is correct, the build or the descriptor, and patch that.]

>
> (2)
> Again, is this about a missinf X11?
> http://gump.dotnot.org/xml-xerces2/dist-xerces.html
> "
>   [java] Exception in thread "main" java.lang.InternalError: Can't
> connect to X11 window server using ':0.0' as the value of the DISPLAY
> variable.
> "

Yup, I added that -Djava.awt.headless=true, sadly it wasn't a magic fix.
Maybe I'll write to the team and ask what they are doing that needs this. I
suspect it is some JDK thing below them, but I do need to find a fix. I
don't think we can expect X11 to be where it isn't wanted.

> (3)
> Is a jar not installed correctly?
> http://gump.dotnot.org/aspectj/aspectj.html

I am bummed I just don't see what I am missing with rsync. I tried the
command line Leo gave me, and it worked first time. Later Stefan added this
to LSD. I re-ran the command, no update. I scoured the man pages and tried
some other options. I forget why (I tried a lot) but these are what I am
currently using. It tells me that aspectj is "up to date"

[ajack@nyx jakarta-gump]$ more ~/syncWithLeo.sh
#!/bin/bash

rsync -arcvvz --delete --stats --rsh="ssh"
ajack@lsd.student.utwente.nl:/data/gump/opt /var/gump/opt

but:

[...]
opt/aspectj1.0/lib/aspectj-ant.jar is uptodate
opt/aspectj1.0/lib/aspectjrt.jar is uptodate
opt/aspectj1.0/lib/aspectjtools.jar is uptodate
opt/aspectj1.1/LICENSE-AspectJ.html is uptodate
opt/aspectj1.1/README-AspectJ.html is uptodate
[...]

(P.S. Not the opt/ .. /var/gump/opt.)

and :

[ajack@nyx jakarta-gump]$ echo /var/gump/opt/asp*
/var/gump/opt/aspectj1.0

Maybe I messed things up by touch the destination directory (I tried
creating the directory once) could that leave timestamp issues that rsync
won't fix? Maybe I have the wrong commandline. I think the lack of '/' is
correct.

Can anybody shed any light on this?

regards,

Adam


Mime
View raw message