gump-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nicola Ken Barozzi <nicola...@apache.org>
Subject Re: Python Gump...
Date Fri, 25 Apr 2003 18:25:21 GMT

Sam Ruby wrote, On 25/04/2003 2.11:
> Adam Jack wrote:
> 
>> Just took the latest from CVS and tried this below. Am I doing something
>> wrong?
>>
>> F:\data\CommonsVersion\Gump>python python\gen.py
>>
>>  ****************************************************************
>>       Error
>>  ****************************************************************
>>  **                                                            **
>>     workspace wdn086.xml not found
> 
> 
> I have much better luck with the following line commented out:
> 
>    os.chdir(dir.base)
> 
> This is the conversation that NKB and I were having this morning.  My 
> assumption is that most people will like to work out of the directory 
> that contains the workspace that they define.  NKB seems to assume that 
> most people would prefer to work out of the directory that the 
> implementation is in.

And IIUC we decided to make Gump work from any directory; I just haven't 
gotten round to inserting and checking your patch.

It's national holiday here in Italy, so I had a day with my family :-)

>> So -- I tried moving into the python directory. And did/got:
>>
>> F:\data\CommonsVersion\Gump\python>gen.py
>> Traceback (most recent call last):
>>   File "F:\data\CommonsVersion\Gump\python\gen.py", line 81, in ?
>>     if f:
>> NameError: name 'f' is not defined
> 
> 
> What version of python are you using?  I'm using ActiveState's.  By any 
> chance are you using cygwin's?

FYI I'm using the one that comes on the python site, so IIUC it's a 
third. It's good we all have different versions :-)

BTW, I get the same error some times, don't remember exactly when, but 
basically the error has nothing to do with the "'f' is not defined" message.

-- 
Nicola Ken Barozzi                   nicolaken@apache.org
             - verba volant, scripta manent -
    (discussions get forgotten, just code remains)
---------------------------------------------------------------------


Mime
View raw message