gump-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Adam Jack" <aj...@TrySybase.com>
Subject RE: Package jar by id
Date Wed, 02 Apr 2003 22:35:49 GMT
Once again I spoke a little too soon. The gen.sh "worked" but the build gave
this for commons-vfs:

	Missing prereq
/homelocal/build/packages/jakarta-slide/dist/client/lib/slide-webdavlib.jar
from jakarta-slide

	Missing prereq /homelocal/build/gump-ws/jcifs/jcifs-0.7.1.jar from jcifs

	Missing prereq /homelocal/build/gump-ws/jsch/dist/lib/jsch-gump.jar from
jsch

I can understand the first (although I'd rather not see it, help
appreciated...) but the second/third I have no clue about. I commented out
those dependencies. Is something cached that I can clean out?

regards

Adam
-----Original Message-----
From: Adam Jack [mailto:ajack@trysybase.com]
Sent: Monday, March 31, 2003 8:40 AM
To: 'Gump code and data'
Subject: RE: Package jar by id



	> 	  <project name="jakarta-slide" package="jakarta-slide" />

	Did you provide a new module definition for slide or use the old one
	(with <cvs> and <ant> and all that)?

Since I know nothing about slide, I used the original.

	> I tried including it in my profile, but then it tries to build it.

	Hmm, remove the <ant> part from the definition.

I did, along with the <depends>, and (not sure why, mis-read this to start
off with) the <cvs> and I removed the remove="true" (jut in case) --- and it
worked. Thank you.

Clearly [to my understanding level] it would seem a nice to have would be
the ability to install packages but use the existing module definitions...
Whenever I edit a definition I risk loosing future updates by the module
owners, I risk introducing errors, etc. Is this something that others think
Gump could do -- i.e. utilize the module definition (when a package) but not
attempt to build it?

regards,

Adam


---------------------------------------------------------------------
To unsubscribe, e-mail: gump-unsubscribe@jakarta.apache.org
For additional commands, e-mail: gump-help@jakarta.apache.org


Mime
View raw message