gump-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Carsten Ziegeler" <>
Subject RE: [New build system] Status of samples
Date Mon, 03 Mar 2003 10:42:04 GMT

> -----Original Message-----
> From: Sam Ruby []
> Sent: Friday, February 28, 2003 5:36 PM
> To:
> Cc:
> Subject: Re: [New build system] Status of samples
> Carsten Ziegeler wrote:
>  >> First, my feeling is that if there is a better syntax, I would like
>  >> to simply adopt it.  I don't care what the definition of better is:
>  >> technical, community, whatever.
>  >>
>  > So where is the right place to discuss the syntax? In short: Cocoon
>  > has many dependencies but the description for the dependencies is a
>  > little bit confusing (at least for me), and has some shortcommings.
>  > There is for example no common naming scheme for dependencies, so you
>  > can for example call fop either fop, or xml-fop or whatever you want.
> I'd recommend the mailing list.  But I am 
> willing to discuss it anywhere.  At the moment, the following is 
> effectively the equivalent of an alias:
>    <project name="jakarta-ant">
>      <depend project="ant" inherit="jars"/>
>    </project>
> We could make this simpler with a new <alias/> tag that has the same 
> effect.  Thoughts?
I'm not sure if this helps, this ends up in many aliases. Looking at
the current thread about a apache jar repository, I think we have the 
same problem here: useful names.
I think, for each project there should only be one definite name
which is the project name. So, for fop I guess the project name is rather
xml-fop (as the cvs) than fop - so in the gump descriptors only xml-fop
should be used and nothing else.
And this leads to the names of the jars for those projects, which means
the jar should be named "xml-fop-VERSION.jar".

For example, you can simply test for the availability of a library by
searching for a jar name "PROJECT-ANY_VERSION.jar" or "PROJECT-*.jar".

So, at the end, this has not so much to do with gump, but with a common
naming scheme for asf projects.


View raw message