guacamole-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike Jumper <mjum...@apache.org>
Subject Re: Compile Fails, Does Not Find libjpeg-turbo
Date Fri, 07 Jun 2019 19:47:36 GMT
In general, on a platform using RPM packages, the convention is to separate
the binaries of a library (libfoo) from the headers required to compile
software against that library (libfoo-devel). An RPM that has already been
built against a particular library can thus simply depend on the binary
package for that library, and the user need not have a bunch of development
headers installed that are not needed. Compiling software against the
library would require both the binary and the development packages.

Debian, Ubuntu, etc. follow similar conventions with "-dev" instead of
"-devel".

The fact that this worked for you before after installing only one package
without the conventional "-devel" suffix suggests that the maintainers of
that package did not follow that convention. Nothing within RPM inherently
requires that the maintainer follow those conventions, of course, nor that
they document that they didn't follow those conventions, nor that the
package actually contain what is expected vs. a post-install script that
runs "rm -rf /". Caveat emptor.

- Mike


On Wed, Jun 5, 2019 at 12:22 PM Zer0Cool <melin3710@gmail.com> wrote:

> Sorry, correction...
>
> libjpeg-turbo-devel
>
>
>
> --
> Sent from:
> http://apache-guacamole-general-user-mailing-list.2363388.n4.nabble.com/
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@guacamole.apache.org
> For additional commands, e-mail: user-help@guacamole.apache.org
>
>

Mime
View raw message