guacamole-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike Jumper <mjum...@apache.org>
Subject Re: Can't get the client installed
Date Fri, 07 Jun 2019 19:57:30 GMT
On Thu, Jun 6, 2019 at 11:38 AM Goran <sendmailtogoran@gmail.com> wrote:

> I've done this:
>
> rm -rf guacamole-client/
> git clone https://github.com/apache/guacamole-client.git
> cd guacamole-client/
> mvn package
>
> And got this output. Maybe I'm missing some package?
> ...
> Error while generating Javadoc:
> [ERROR] Exit code: 1 - javadoc: error - The code being documented uses
> modules but the packages defined in
> http://docs.oracle.com/javase/6/docs/api/ are in the unnamed module.
> ...


Not sure. It looks like this is a known issue either with the Maven javadoc
plugin, with the javadoc tool, or both., and specifically with newer
versions of the JDK:

https://bugs.openjdk.java.net/browse/JDK-8212233

>From the above, it looks like a minor change to the pom.xml wherever the
javadoc plugin is being configured may resolve things, informing javadoc
that the code being documented is written for compatibility with Java 8. A
similar issue was mentioned on the mailing list last month, with the user
later noting the problem as solved by switching to JDK 8:

https://lists.apache.org/thread.html/b82c6ed4c73af93a46e4efc1eb8b6a7d5c36cde382a12574e90873e7@%3Cuser.guacamole.apache.org%3E

Perhaps there is more at work here than simply needing a specific JDK.

- Mike

Mime
View raw message