guacamole-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nick Couchman <vn...@apache.org>
Subject Re: SSH and ED25519 not supported?
Date Mon, 03 Jun 2019 00:29:40 GMT
> Thanks for the answer.
>
> libssh2 has so many dependencies in Centos 7, will be hard to update I
> think.
>

My experience is the opposite with libssh2 - doesn't seem like it requires
all that many things installed, and almost nothing else relies upon because
most everything else uses OpenSSH instead of libssh2.


>
> I compiled libssh2 1.8 and installed it in /usr/local/lib. Edited the
> systemd file of guacd.service and put
>
>     [Service]
>     Environment="LD_PRELOAD=/usr/local/lib/libssh2.so"
>
> in it. But does not work. Anybody an idea how to load the new library for
> guacd?
>
>
What I usually do for CentOS 7 is try to build a newer RPM for libssh2 and
install/upgrade that - it's reasonably easy to grab the .spec file from the
SRC RPM for the distribution and just update it for the newer version.  As
I recall there wasn't much different in the build process, so it should be
a pretty seamless build.  Once you have the new rpm just "rpm -Uvh" and
you're good to go.

-Nick

>

Mime
View raw message