guacamole-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vieri <rentor...@yahoo.com>
Subject Re: guacamole LDAP seeAlso group
Date Sun, 05 May 2019 16:01:51 GMT

On Thursday, May 2, 2019, 5:04:54 PM GMT+2, Vieri <rentorbuy@yahoo.com> wrote: 
>
> ----- Forwarded Message -----
>
> I always get an "Unable to query list of ojects from LDAP diretcory" message.

Today I cloned guacamole-client with git. After installing both the war file and the ldap
module, my user can finally successfully see all the connections, even those pointing to a
group with seeAlso. So it seems that the LDAP code is now working fine in GIT as far as groups/seeAlso
is concerned. However, as soon as I try to connect to any underlying systems, I get unusual
behavior.

For instance, I have a telnet service I can connect to, but it's as if guacamole were sending
ENTER keystrokes automatically (so I can't even log into the Telnet service).

Also, I can connect to a Windows Server 2003, and I see Windows's user login screen for a
fraction of a second, but a pop-up shows up and immediately closes the session (I can't even
log-in or even read this message -- granted I haven't searched the server's event log yet).

Finally, an RDP/LNA connection to a Windows 2012 R2 immediately fails (cannot log-in).

With Guacamole 1.0.0 release I can successfully connect to any one of the 3 examples above. 
Only LDAP is misbehaving in 1.0.0.

If I try to use the GIT 1.1.0 LDAP module with Guacamole client 1.0.0 I get an invalid login.

Any ideas?

Thanks,

Vieri

Mime
View raw message