guacamole-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike Jumper <mjum...@apache.org>
Subject Re: Issue with branding extension on 1.0.0
Date Thu, 28 Mar 2019 17:35:29 GMT
Try earlier in those logs, from the point that Tomcat started (not tail
-f), or a different log like catalina.out or the systemd journal. If you
have the right file, there will be several messages from Guacamole even if
there aren't any errors, including a message that notes the location of
GUACAMOLE_HOME and messages noting each extension being loaded.

If you do not see at least the above messages, the proper logs must be
elsewhere - either earlier in the file or in a different log entirely.

- Mike


On Thu, Mar 28, 2019 at 10:27 AM <harry.devine@faa.gov> wrote:

> Only this, but when I reloaded the page, nothing got added to it (I think
> what I have below was from when Tomcat got restarted about 30 minutes ago):
>
>
>
> [root@armt.ts.faa.gov ~/guacbranding]#tail -f
> /var/log/tomcat/catalina.2019-03-28.log
>
> Mar 28, 2019 1:09:18 PM org.apache.catalina.startup.TldConfig execute
>
> INFO: At least one JAR was scanned for TLDs yet contained no TLDs. Enable
> debug logging for this logger for a complete list of JARs that were scanned
> but no TLDs were found in them. Skipping unneeded JARs during scanning can
> improve startup time and JSP compilation time.
>
> Mar 28, 2019 1:09:18 PM org.apache.catalina.startup.HostConfig
> deployDirectory
>
> INFO: Deployment of web application directory
> /var/lib/tomcat/webapps/manager has finished in 229 ms
>
> Mar 28, 2019 1:09:18 PM org.apache.coyote.AbstractProtocol start
>
> INFO: Starting ProtocolHandler ["http-bio-8080"]
>
> Mar 28, 2019 1:09:18 PM org.apache.coyote.AbstractProtocol start
>
> INFO: Starting ProtocolHandler ["ajp-bio-8009"]
>
> Mar 28, 2019 1:09:18 PM org.apache.catalina.startup.Catalina start
>
> INFO: Server startup in 5933 ms
>
>
>
> Thanks,
>
> Harry
>
>
>
> *From:* Mike Jumper <mjumper@apache.org>
> *Sent:* Thursday, March 28, 2019 1:23 PM
> *To:* user@guacamole.apache.org
> *Subject:* Re: Issue with branding extension on 1.0.0
>
>
>
> Do you see anything in the Tomcat+Guacamole logs?
>
>
>
> - Mike
>
>
>
> On Thu, Mar 28, 2019, 10:13 <harry.devine@faa.gov> wrote:
>
> I fixed that error in the manifest and restarted everything.  The apache
> error log shows this when I load the page:
>
>
>
> [Thu Mar 28 13:10:38.853330 2019] [proxy_http:error] [pid 12362]
> (70008)Partial results are valid but processing is incomplete: [client
> 172.31.26.83:55068] AH01110: error reading response, referer:
> http://armt.ts.faa.gov/
>
>
>
> 0.9.13 is running on 2 separate servers/installations.  This new server is
> the only one that we have 1.0.0 on at the moment, so there’s no chance of
> anything being crossed (0.9.13 affecting 1.0.0 or vice versa).
>
>
>
> Thanks,
>
> Harry
>
> *From:* Mike Jumper <mjumper@apache.org>
> *Sent:* Thursday, March 28, 2019 11:23 AM
> *To:* user@guacamole.apache.org
> *Subject:* Re: Issue with branding extension on 1.0.0
>
>
>
> On Thu, Mar 28, 2019 at 7:29 AM <harry.devine@faa.gov> wrote:
>
> ...
>
>   "resources" : {
>
>     "resources/ARMTLogo.png" : "ARMTLogo.png"
>
>   },
>
>
>
> By the way, I'm not sure if this is related to the problem at hand, but
> this is incorrect. The value of each property within "resources" should be
> the mimetype of that resource. This should instead be:
>
>
>
>   "resources" : {
>
>     "resources/ARMTLogo.png" : "image/png"
>
>   },
>
>
>
> See: http://guacamole.apache.org/doc/gug/guacamole-ext.html#ext-manifest
>
>
>
> - Mike
>
>
>
>

Mime
View raw message