guacamole-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert Dinse <nan...@eskimo.com>
Subject Re: Compile Error
Date Mon, 25 Feb 2019 00:32:55 GMT

      I got the same error, possible or not.  The patch was AFTER the line
that errored so don't see how it would have fixed the error anyway.

-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-
  Eskimo North Linux Friendly Internet Access, Shell Accounts, and Hosting.
    Knowledgeable human assistance, not telephone trees or script readers.
  See our web site: http://www.eskimo.com/ (206) 812-0051 or (800) 246-6874.

On Sun, 24 Feb 2019, Mike Jumper wrote:

> Date: Sun, 24 Feb 2019 15:56:30 -0800
> From: Mike Jumper <mjumper@apache.org>
> Reply-To: user@guacamole.apache.org
> To: user@guacamole.apache.org
> Subject: Re: Compile Error
> 
> It's not possible for the same error to be present with the patched code.
> The line in question no longer exists with the patch, having been replaced
> with a call to guac_strlcpy(). If you're still seeing an error on that line
> regarding strncpy(), you're not building the patch that Nick mentioned.
>
> - Mike
>
> On Sun, Feb 24, 2019 at 3:46 PM Robert Dinse <nanook@eskimo.com> wrote:
>
>>
>>       That patch isn't going to fix it, at leat not under Ubuntu, as I
>> applied
>> it and still got the same compile error.
>>
>>
>> -_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-
>>   Eskimo North Linux Friendly Internet Access, Shell Accounts, and Hosting.
>>     Knowledgeable human assistance, not telephone trees or script readers.
>>   See our web site: http://www.eskimo.com/ (206) 812-0051 or (800)
>> 246-6874.
>>
>> On Sun, 24 Feb 2019, Nick Couchman wrote:
>>
>>> Date: Sun, 24 Feb 2019 07:13:17 -0500
>>> From: Nick Couchman <vnick@apache.org>
>>> Reply-To: user@guacamole.apache.org
>>> To: user@guacamole.apache.org
>>> Subject: Re: Compile Error
>>>
>>> On Sun, Feb 24, 2019 at 5:48 AM Robert Dinse <nanook@eskimo.com> wrote:
>>>
>>>>
>>>>       Pulled the source from github and attempted to compile on Ubuntu
>>>> 18.10 but
>>>> got the following error:
>>>>
>>>> guac_svc/svc_service.c: In function ÿÿÿÿVirtualChannelEntryÿÿÿÿ:
>>>> guac_svc/svc_service.c:56:5: error: ÿÿÿÿstrncpyÿÿÿÿ output may be
truncated
>>>> copying 7 bytes from a string of length 7 [-Werror=stringop-truncation]
>>>>       strncpy(svc_plugin->plugin.channel_def.name, svc->name,
>>>>       ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
>>>>               GUAC_RDP_SVC_MAX_LENGTH);
>>>>               ~~~~~~~~~~~~~~~~~~~~~~~~
>>>>
>>>>       Any suggestions as to how to fix?  Normally an error like this
>> would
>>>> not stop a compile but directives are given that cause all warnings to
>> be
>>>> treated as errors so this stops the compile.
>>>>
>>>
>>> Looks like you're hitting this issue:
>>>
>>> https://issues.apache.org/jira/browse/GUACAMOLE-637
>>>
>>> which has an active pull request that is being review and will hopefully
>> be
>>> merged, soon.  Should be fixed in version 1.1.0.
>>>
>>> https://github.com/apache/guacamole-server/pull/209
>>>
>>> -Nick
>>>
>
Mime
  • Unnamed multipart/mixed (inline, None, 0 bytes)
View raw message