guacamole-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brian Haskell <...@ams.org>
Subject RE: Unable to query list of objects from LDAP directory.
Date Fri, 25 Jan 2019 15:05:45 GMT
I'm having this same issue with 1.0.0 on a full install (no docker)
I have an older 0.9.12 install running LDAP just fine using the following settings

 ldap-hostname: adserver.aaa.org
ldap-port: 3268
ldap-encryption-method: none
ldap-search-bind-dn: binduser
ldap-search-bind-password: ********
ldap-user-base-dn: DC=aaa,DC=org
ldap-username-attribute: sAMAccountName

Same 'Unable to query list of objects from LDAP directory' in red at the top of the screen
yet the catalina.out reads:

09:46:26.618 [http-nio-8080-exec-1] INFO  o.a.g.r.auth.AuthenticationService - User "aaaaa"
successfully authenticated from 10.xx.xx.xx.


I'm trying to stand up this instance clean (will import the database from our production guac
server later) and am stuck here.



From: Christian Kraus <christian.kraus@ckc-it.at>
Sent: Friday, January 25, 2019 7:50 AM
To: user@guacamole.apache.org
Subject: AW: Unable to query list of objects from LDAP directory.


Hi



I think this setting is wrong :-e LDAP_HOSTNAME=mydomain.aaa.com \

it should be -e LDAP_HOSTNAME=dcserver.mydomain.aaa.com \





rg

Christian




[cid:image001.jpg@01D4B494.B72A9E10]














-----Urspr√ľngliche Nachricht-----
Von: Daniel Brienza <daniel.brienza@protonmail.com<mailto:daniel.brienza@protonmail.com>>
Gesendet: Freitag 25 Januar 2019 12:38
An: user@guacamole.apache.org<mailto:user@guacamole.apache.org>
Betreff: Unable to query list of objects from LDAP directory.


I'm trying to configure a container with LDAP authentication from my active directory domain
but I'm receiving the error message below on web interface after login:
Unable to query list of objects from LDAP directory.

I don't see any error message on logs, it shows as it successfully authenticated:
1:13:28.610 [http-nio-8080-exec-7] INFO  o.a.g.r.auth.AuthenticationService - User "my.user"
successfully authenticated from 10.0.0.0.

Container configuration:

docker run --name my-guacamole --link my-guacd:guacd \
    --link my-guaca-postgres:postgres \
    -e POSTGRES_DATABASE=guacamole_db \
    -e POSTGRES_USER=guacamole_user \
    -e POSTGRES_PASSWORD=password \
    -e LDAP_HOSTNAME=mydomain.aaa.com \
    -e LDAP_PORT=389 \
    -e LDAP_USER_BASE_DN=OU=BU,DC=MYDOMAIN,DC=aaa,DC=com \
-e LDAP_SEARCH_BIND_DN=CN=BindUsers,OU=Infra,OU=IT,OU=Users,OU=BU,DC=MYDOMAIN,DC=aaa,DC=com
\
    -e LDAP_SEARCH_BIND_PASSWORD=password \
    -e LDAP_USERNAME_ATTRIBUTE=sAMAccountName \
    -d -p 8080:8080 guacamole/guacamole

Mime
View raw message