guacamole-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike Jumper <mjum...@apache.org>
Subject Re: Sound not working on custom application
Date Mon, 03 Dec 2018 19:47:01 GMT
On Mon, Dec 3, 2018 at 11:37 AM hank08 <ahanke@osii.com> wrote:

> I created my own application following Chapter 23 of the guacamole guide. I
> implemented it using the websocket tunnel instead of the http tunnel.  I am
> using rdp to connect to a windows 10 machine.  Everything works fine except
> for the sound.  To implement my custom application I cloned a VM that had a
> standalone instance of guacamole and just replaced the tomcat portion with
> my custom web app so I dont think it should have anything to do with
> guacd.
> I also don't get any error in the logs for guacd.  Is there something I
> have
> to do on the javascript side to enable the sound?  Or perhaps on the java
> side I have to enable something to make the sound pass through?
>

The dev@ list would probably have been a better choice, but:

What value(s) are you giving for the client-supported audio mimetypes via
your GuacamoleClientInformation object? If you aren't already doing so, you
will need to test what audio codecs are supported on the client side and
forward that information through so that the tunnel can supply it to guacd
during the handshake. Example of this in practice:

https://github.com/apache/guacamole-client/blob/fc457c080d813044e30e1f4e8fe855d6a5900259/guacamole/src/main/java/org/apache/guacamole/tunnel/TunnelRequestService.java#L155-L158

Also see Guacamole.AudioPlayer.getSupportedTypes():

https://guacamole.apache.org/doc/guacamole-common-js/Guacamole.AudioPlayer.html#.getSupportedTypes

- Mike

Mime
View raw message