guacamole-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Not Speedy <notspeed...@gmail.com>
Subject Re: guacamole 1.0.0 and radius extension
Date Sun, 02 Dec 2018 03:10:08 GMT
commented out the logging as a way to keep the plugin from crashing.. Now
that its not crashing it doesn't seem to even try to authenticate.  using
radtest, I'm able to confirm the radius server is reachable from the
guacamole server. I've numbered the authproviders 0radius and 1jbdc as
suggested in another thread.  that did not help.  My guacamole property
files looks like this

# MySQL properties
mysql-hostname: localhost
mysql-port: 3306
mysql-database: guacdb
mysql-username: xxxxxxx
mysql-password: xxxxxxxx

# Additional settings
mysql-default-max-connections-per-user: 0
mysql-default-max-group-connections-per-user: 0

radius-server: 10.xxx.xxx.xx
radius-auth-port: 1812
radius-shared-secret: xxxxxx
radius-auth-protocol: pap
radius-retries:3
radius-timeout:10

any thoughts?


On Sat, Dec 1, 2018 at 7:29 PM Not Speedy <notspeedy01@gmail.com> wrote:

> Thanks for the help Nick.  I just tried from scratch with the same
> results. Perhaps it my ide,...I'll continue to keep googling and trying.
> I'll also try against the staging branch to see if my results differ.
>
> Thanks again
>
> On Sat, Dec 1, 2018 at 6:30 PM Nick Couchman <vnick@apache.org> wrote:
>
>> On Sat, Dec 1, 2018 at 7:06 PM Not Speedy <notspeedy01@gmail.com> wrote:
>>
>>> odd..the only war/app I have is guacamole, and its the only project i
>>> currently have imported into intellij. I'm building off master.  It looks
>>> like the lib is being pulled in with the mavin-dependency-plugin, during
>>> the build... but I could be wrong.  I'll keep playing with it.  I'm very
>>> new with maven and building things from source.
>>>
>>>
>> I've been trying it out from staging/1.0.0 instead of master, so I'll try
>> to find some time to try out the master branch and see if something might
>> be broken, there.  In the meantime, I'd suggest cleaning out all of your
>> builds, and all of your extensions and re-deploying things from the
>> beginning and see if that helps.
>>
>> -Nick
>>
>>>

Mime
View raw message