guacamole-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike Jumper <mjum...@apache.org>
Subject Re: warning in guacamole 1.0.0
Date Mon, 12 Nov 2018 14:26:23 GMT
On Mon, Nov 12, 2018, 05:22 fou fe <fouhane@live.fr wrote:

> Hi
>
> In guacamole 1.0.0  everything work like a charm but  I have this warning
> in catalina.out.
>
>
> 12:48:15.186 [http-nio-8080-exec-10] INFO
>  o.a.g.r.auth.AuthenticationService - User "XXXX" successfully
> authenticated from XXX.XX.XX.XX.
> WARNING: An illegal reflective access operation has occurred
> WARNING: Illegal reflective access by
> org.apache.ibatis.reflection.Reflector
> (file:/etc/guacamole/extensions/guacamole-auth-jdbc-mysql-1.0.0.jar) to
> method java.util.HashMap.hash(java.lang.Object)
> WARNING: Please consider reporting this to the maintainers of
> org.apache.ibatis.reflection.
>

This is an outstanding bug in MyBatis (the database mapping library we use)
due to changes in JDK 9:

https://github.com/mybatis/mybatis-3/issues/1156


>  Do you have any idea to fix this warning ?
>

I don't believe there is a way to fix this warning except to eventually
upgrade the database auth to a version of MyBatis which fixes the warning.

No such version of MyBatis is yet released.

- Mike

Mime
View raw message