guacamole-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nick Couchman <vn...@apache.org>
Subject Re: LDAP authentication problem
Date Wed, 26 Sep 2018 14:08:29 GMT
On Wed, Sep 26, 2018 at 6:25 AM Galyrith <quentin.lucas@umontpellier.fr>
wrote:

> # LDAP Properties
> ldap-hostname: pin.isim.intra
> ldap-port: 389
> ldap-user-base-dn: UO=Comptes,DC=isim,DC=intra
> ldap-search-bind-dn: CN=Bind,UO=Comptes,DC=isim,DC=intra
> ldap-search-bind-password: xxxxxx
> ldap-username-attribute: sAMAccountName
>
> In the tomcat log (catalina.out) my extensions are load but when I try to
> connect, I have as my message:
>
> 11:50:01.674 [http-nio-8080-exec-8] ERROR
> o.a.g.a.l.AuthenticationProviderService - Unable to bind using search DN
> "CN=Bind,DC=isim,DC=intra"
> 11:50:01.674 [http-nio-8080-exec-8] WARN
> o.a.g.r.auth.AuthenticationService
> - Authentication attempt from 162.38.37.135 for user "lucas.isim.intra"
> failed.
>
> I saw that many people encountered this problem but none of the solutions
> work with my problem.
>
>
Two things, I notice, here.  First, the most basic indication of this error
message is that your bind DN and/or password are incorrect.  However, I
also notice that the bind DN you have in the LDAP properties you sent is
different from the one in your error message.  In LDAP properties it is
specified as "CN=Bind,UO=Comptes,DC=isim,DC=intra", while the error message
shows "CN=Bind,DC=isim,DC=intra".  Did you change/update the
ldap.properties at some point, and have you either restarted Tomcat or
re-deployed the Guacamole web application to pull in the new settings?

-Nick

Mime
View raw message