guacamole-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Kraus <christian.kr...@ckc-it.at>
Subject AW: Newbie having trouble getting RDP working
Date Mon, 13 Aug 2018 06:00:59 GMT
Hi,



You must set the security in the connection config to TLS with windows 2012 and newer



rg



Christian




Christian Kraus
Inhaber
CKC IT Consulting & Solutions e.U.
Kirschenallee 22
2120 OBERSDORF
Österreich
Telefon: +43 (0) 680 2062952
Fax:        +43 820 220262992
E-mail: christian.kraus@ckc-it.at

-----Ursprüngliche Nachricht-----
Von: Rhys Ferris <rhys.j.ferris@gmail.com>
Gesendet: Montag 13 August 2018 04:02
An: user@guacamole.apache.org
Betreff: Newbie having trouble getting RDP working

Hello all,

 
Forgive me for any noob questions or omissions, I subscribe to a “learn it as I go” model.

I’m having trouble getting RDP to work on my Guacamole setup. I’m using it for KVM virtual
machines on a bridged adapter.

RDP works into the VM from my workstation that is not the same box as guacamole is running
on.

 
Host: Ubuntu Server 18.04.1 LTS

Guest: Virtual Windows Server 2016 (VM I’m trying to RDP into)

Guacamole Version: 0.9.14

Libfreerdp-dev version: 1.1.0~git20140921.1.440916e+dfsg1-15ubuntu1

 
When I try to open through guacamole I get the following in the web browser:

“The remote desktop server is currently unreachable. If the problem persists, please notify
your system administrator, or check your system logs.”

 
Syslog shows this:

Aug 12 20:53:49 odin guacd[4234]: Creating new client for protocol "rdp"


Aug 12 20:53:49 odin guacd[4234]: Connection ID is <omitted>"

Aug 12 20:53:49 odin guacd[14988]: No security mode specified. Defaulting to RDP.

Aug 12 20:53:49 odin guacd[14988]: Resize method: none

Aug 12 20:53:49 odin guacd[14988]: User "@<omitted>" joined connection "$<omitted>"
(1 users now present)

Aug 12 20:53:49 odin guacd[14988]: Loading keymap "base"

Aug 12 20:53:49 odin guacd[14988]: Loading keymap "en-us-qwerty"

Aug 12 20:53:49 odin guacd[14988]: Failed to load guacdr plugin. Drive redirection and printing
will not work. Sound MAY not work.

Aug 12 20:53:49 odin guacd[14988]: Failed to load guacsnd alongside guacdr plugin. Sound will
not work. Drive redirection and printing MAY not work.

Aug 12 20:53:52 odin guacd[14988]: Error connecting to RDP server

Aug 12 20:53:52 odin guacd[14988]: User "@<omitted>" disconnected (0 users remain)

Aug 12 20:53:52 odin guacd[14988]: Last user of connection "$<omitted>" disconnected

Aug 12 20:53:52 odin guacd[4234]: Connection "$<omitted>" removed.

 
I do not show any failed attempts to connect in the event viewer. I’m looking in Applications
and Services Logs > Microsoft > Windows > TerminalServices-LocalSessionsManager >
Operational

 
My user.mapping for rdp is this:

<connection name="RDP">

                <protocol>rdp</protocol>

                <param name="hostname">172.16.99.162</param>

                <param name="port">3389</param>

                <param name="enable-wallpaper">true</param>

</connection>

 
Use of the Google Machine found someone else with these exact errors some years ago and they
fixed by removing the requirement for NLA on the server. Tried this, didn’t help.

 
VNC and SSH work fine.

 
Prerequisite check showed good for RDP before building

This is the first thing I’ve built like this. Used official documentation from the website.

 
Not sure where to go next for troubleshooting. Rebuild? I hope not. Any advice appreciated.

 
Thanks for any help.

 
Sent from Mail for Windows 10

 

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message