guacamole-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ivanmarcus <ivanmar...@yahoo.com>
Subject Re: SSH issue with Ubuntu 18.04 - updated detail
Date Mon, 13 Aug 2018 20:58:58 GMT
Sigh, I always seem to find the answer just after sending an email 
saying it won't work!

Just installed libssh2-1-dev (from 
http://security.ubuntu.com/ubuntu/pool/universe/libs/libssh2/libssh2-1-dev_1.8.0-1_amd64.deb),

and libpango1.0-dev (native), and it now compiles with ssh/ssh. This is 
with some symbolic links in place so whether it'd work without I'm not 
sure at this stage.

Unfortunately I need to do some work right now but if it's useful I'll 
have another go with a fresh Ubuntu 18.04 tomorrow, and confirm what's 
needed from scratch with locations for downloading required packages as 
needed.

FWIW this is what I obtained externally and installed to date:

https://www.openssl.org/source/openssl-1.0.2g.tar.gz
http://ftp.br.debian.org/debian/pool/main/h/harfbuzz/libharfbuzz-dev_1.4.2-1_amd64.deb
http://ftp.br.debian.org/debian/pool/main/p/pango1.0/libpangoft2-1.0-0_1.40.5-1_amd64.deb
http://ftp.br.debian.org/debian/pool/main/p/pango1.0/libpangocairo-1.0-0_1.40.5-1_amd64.deb
http://archive.ubuntu.com/ubuntu/pool/universe/o/ossp-uuid/libossp-uuid16_1.6.2-1.5build4_amd64.deb
http://archive.ubuntu.com/ubuntu/pool/universe/o/ossp-uuid/libossp-uuid-dev_1.6.2-1.5build4_amd64.deb
http://archive.ubuntu.com/ubuntu/pool/universe/libs/libssh2/libssh2-1_1.8.0-1_amd64.deb

Not all may be necessary(?)


On 14/08/2018 8:41 a.m., ivanmarcus wrote:
>
> libssl-dev is the one.
>
> Earlier I'd discovered that the directory paths between 16.04 and 
> 18.04 were quite different for some installed packages. If I put in 
> some symbolic links it fixed some of the 'missing' issues, but it 
> seemed like a long process and I'm sure there's a better way!
>
> Anyway libssl-dev was the final step to getting it to compile with 
> ssl, but still no recognised libssh2 (despite it being in place), nor 
> pango (also in place).
>
> FWIW the install to date wasn't easy, had to go looking for some 
> packages in odd places and we're still not working. I expect just 
> adding the repository and installing from there would be much more 
> straightforward (?) but I guess that won't sort out the issues with 
> this script and Nate's lack of ssh...
>
>
> On 13/08/2018 10:45 p.m., Nick Couchman wrote:
>>
>>
>> On Sun, Aug 12, 2018 at 22:19 ivanmarcus <ivanmarcus@yahoo.com 
>> <mailto:ivanmarcus@yahoo.com>> wrote:
>>
>>
>>     checking openssl/ssl.h usability... no
>>     checking openssl/ssl.h presence... no
>>     checking for openssl/ssl.h... no
>>     checking for SSL_CTX_new in -lssl... no
>>     configure: WARNING:
>>       --------------------------------------------
>>        Unable to find libssl.
>>        guacd will not support SSL connections.
>>       --------------------------------------------
>>
>>
>> Looks like maybe the OpenSSL development package is missing?  I can't 
>> remember what it is on Ubuntu, but probably something like libssl-dev 
>> or openssl-dev or something like that?
>>
>> If I have a chance today I'll spin up that version and see what I can 
>> figure out.
>>
>> -Nick
>


Mime
View raw message