guacamole-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nick Couchman <vn...@apache.org>
Subject Re: SSH issue with Ubuntu 18.04 - updated detail
Date Wed, 15 Aug 2018 00:35:52 GMT
On Tue, Aug 14, 2018 at 5:54 PM ivanmarcus <ivanmarcus@yahoo.com> wrote:

> Further to previous detail I resumed my install testing on a brand-new
> Ubuntu 18.04 server.
>
> For me the MysticRyuujin script would not work and it failed, unable to
> locate a number of packages.
>
> I then proceeded to build the guacamole-server per chapt 2 of the manual
> (Installing Guacamole natively)
>
> Several required and optional packages were unavailable and I needed to
> get a .deb package elsewhere to install.
>
> The following is the step-by-step process required (note I was building
> for ssh only:
>
>
>
I was able to get it built and installed on Ubuntu 18.04 without having to
manually "wget" any of the files, just using apt-get to install
dependencies:

guac@guachost3:~/guacamole-server$ sudo apt-get install
build-essential autoconf libtool
m4 libpng-dev libjpeg-dev libcairo-dev libossp-uuid-dev libtelnet-dev
libpango1.0-dev libfreerdp-dev
libssh2-1-dev libwebp-dev libvncserver-dev libpulse-dev libvorbis-dev
guac@guachost3:~/guacamole-server$ ./configure --prefix=/opt/guac
guac@guachost3:~/guacamole-server$ make
guac@guachost3:~/guacamole-server$ sudo make install

(Note that this builds for all the protocols, but no guacenc support.)

-Nick

Mime
View raw message