guacamole-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From M D Barber <md...@aol.com>
Subject Re: Newbie having trouble getting RDP working
Date Mon, 13 Aug 2018 11:08:12 GMT
don't think that's true mate, i have rdp/tls working with win7 and 10 
clients with normal logon after connection but I had to have
both the nla turned off on the clients and ignorecert set in the 
connection properties


Adrian Owen wrote:
>
> Hi Rhys,
>
> With TLS you must supply username and password in Guacamole connection.
>
> Disable TLS for console logon.
>
> Adrian
>
> *From:*Rhys Ferris [mailto:rhys.j.ferris@gmail.com]
> *Sent:* 13 August 2018 18:44
> *To:* user@guacamole.apache.org
> *Subject:* RE: Newbie having trouble getting RDP working
>
> Thanks for the quick reply! No joy though. Logs basically the same, 
> except it lists tls now.
>
> Aug 13 06:39:05 odin guacd[26153]: Creating new client for protocol "rdp"
>
> Aug 13 06:39:05 odin guacd[26153]: Connection ID is 
> "$5acd0ada-8435-4999-802e-71bf76e356a9"
>
> Aug 13 06:39:05 odin guacd[26165]: Security mode: TLS
>
> Aug 13 06:39:05 odin guacd[26165]: Resize method: none
>
> Aug 13 06:39:05 odin guacd[26165]: User 
> "@07db7078-1dec-43b3-8547-cc4dba6440a5" joined connection 
> "$5acd0ada-8435-4999-802e-71bf76e356a9" (1 users now present)
>
> Aug 13 06:39:05 odin guacd[26165]: Loading keymap "base"
>
> Aug 13 06:39:05 odin guacd[26165]: Loading keymap "en-us-qwerty"
>
> Aug 13 06:39:05 odin guacd[26165]: Failed to load guacdr plugin. Drive 
> redirection and printing will not work. Sound MAY not work.
>
> Aug 13 06:39:05 odin guacd[26165]: Failed to load guacsnd alongside 
> guacdr plugin. Sound will not work. Drive redirection and printing MAY 
> not work.
>
> Aug 13 06:39:08 odin guacd[26165]: Error connecting to RDP server
>
> Aug 13 06:39:08 odin guacd[26165]: User 
> "@07db7078-1dec-43b3-8547-cc4dba6440a5" disconnected (0 users remain)
>
> Aug 13 06:39:08 odin guacd[26165]: Last user of connection 
> "$5acd0ada-8435-4999-802e-71bf76e356a9" disconnected
>
> Aug 13 06:39:08 odin guacd[26153]: Connection 
> "$5acd0ada-8435-4999-802e-71bf76e356a9" removed.
>
> Rhys
>
> Sent from Mail <https://go.microsoft.com/fwlink/?LinkId=550986> for 
> Windows 10
>
> *From: *Christian Kraus <mailto:christian.kraus@ckc-it.at>
> *Sent: *Monday, August 13, 2018 2:01 AM
> *To: *user@guacamole.apache.org <mailto:user@guacamole.apache.org>
> *Subject: *AW: Newbie having trouble getting RDP working
>
> Hi,
>
> You must set the security in the connection config to TLS with windows 
> 2012 and newer
>
> rg
>
> Christian
>
> cid:md.a4f52ef87dd9cfefe2a1d10c7ee2bc78433597f2@CKCUCS1
>
>
>
>
>
>     -----Ursprüngliche Nachricht-----
>     *Von:* Rhys Ferris <rhys.j.ferris@gmail.com
>     <mailto:rhys.j.ferris@gmail.com>>
>     *Gesendet:* Montag 13 August 2018 04:02
>     *An:* user@guacamole.apache.org <mailto:user@guacamole.apache.org>
>     *Betreff:* Newbie having trouble getting RDP working
>
>     Hello all,
>
>     Forgive me for any noob questions or omissions, I subscribe to a
>     “learn it as I go” model.
>
>     I’m having trouble getting RDP to work on my Guacamole setup.
>     I’m using it for KVM virtual machines on a bridged adapter.
>
>     RDP works into the VM from my workstation that is not the same box
>     as guacamole is running on.
>
>     Host: Ubuntu Server 18.04.1 LTS
>
>     Guest: Virtual Windows Server 2016 (VM I’m trying to RDP into)
>
>     Guacamole Version: 0.9.14
>
>     Libfreerdp-dev version: 1.1.0~git20140921.1.440916e+dfsg1-15ubuntu1
>
>     When I try to open through guacamole I get the following in the
>     web browser:
>
>     “The remote desktop server is currently unreachable. If the
>     problem persists, please notify your system administrator, or
>     check your system logs.”
>
>     Syslog shows this:
>
>     Aug 12 20:53:49 odin guacd[4234]: Creating new client for protocol
>     "rdp"
>
>     Aug 12 20:53:49 odin guacd[4234]: Connection ID is
>     <omitted>"<mailto:%22%0dAug%2012%2020:53:49%20odin%20guacd[14988]:%20No%20security%20mode%20specified.%20Defaulting%20to%20RDP.%0dAug%2012%2020:53:49%20odin%20guacd[14988]:%20Resize%20method:%20none%0dAug%2012%2020:53:49%20odin%20guacd[14988]:%20User%20%22@%3comitted>
>
>     Aug 12 20:53:49 odin guacd[14988]: No security mode specified.
>     Defaulting to
>     RDP.<mailto:%22%0dAug%2012%2020:53:49%20odin%20guacd[14988]:%20No%20security%20mode%20specified.%20Defaulting%20to%20RDP.%0dAug%2012%2020:53:49%20odin%20guacd[14988]:%20Resize%20method:%20none%0dAug%2012%2020:53:49%20odin%20guacd[14988]:%20User%20%22@%3comitted>
>
>     Aug 12 20:53:49 odin guacd[14988]: Resize method:
>     none<mailto:%22%0dAug%2012%2020:53:49%20odin%20guacd[14988]:%20No%20security%20mode%20specified.%20Defaulting%20to%20RDP.%0dAug%2012%2020:53:49%20odin%20guacd[14988]:%20Resize%20method:%20none%0dAug%2012%2020:53:49%20odin%20guacd[14988]:%20User%20%22@%3comitted>
>
>     Aug 12 20:53:49 odin guacd[14988]: User "@<omitted
>     <mailto:%22%0dAug%2012%2020:53:49%20odin%20guacd[14988]:%20No%20security%20mode%20specified.%20Defaulting%20to%20RDP.%0dAug%2012%2020:53:49%20odin%20guacd[14988]:%20Resize%20method:%20none%0dAug%2012%2020:53:49%20odin%20guacd[14988]:%20User%20%22@%3comitted>>"
>     joined connection "$<omitted>" (1 users now present)
>
>     Aug 12 20:53:49 odin guacd[14988]: Loading keymap "base"
>
>     Aug 12 20:53:49 odin guacd[14988]: Loading keymap "en-us-qwerty"
>
>     Aug 12 20:53:49 odin guacd[14988]: Failed to load guacdr plugin.
>     Drive redirection and printing will not work. Sound MAY not work.
>
>     Aug 12 20:53:49 odin guacd[14988]: Failed to load guacsnd
>     alongside guacdr plugin. Sound will not work. Drive redirection
>     and printing MAY not work.
>
>     Aug 12 20:53:52 odin guacd[14988]: Error connecting to RDP server
>
>     Aug 12 20:53:52 odin guacd[14988]: User "@<omitted>" disconnected
>     (0 users remain)
>
>     Aug 12 20:53:52 odin guacd[14988]: Last user of connection
>     "$<omitted>" disconnected
>
>     Aug 12 20:53:52 odin guacd[4234]: Connection "$<omitted>" removed.
>
>     I do not show any failed attempts to connect in the event viewer.
>     I’m looking in Applications and Services Logs > Microsoft >
>     Windows > TerminalServices-LocalSessionsManager > Operational
>
>     My user.mapping for rdp is this:
>
>     <connection name="RDP">
>
>     <protocol>rdp</protocol>
>
>                     <param name="hostname">172.16.99.162</param>
>
>                     <param name="port">3389</param>
>
>                     <param name="enable-wallpaper">true</param>
>
>     </connection>
>
>     Use of the Google Machine found someone else with these exact
>     errors some years ago and they fixed by removing the requirement
>     for NLA on the server. Tried this, didn’t help.
>
>     VNC and SSH work fine.
>
>     Prerequisite check showed good for RDP before building
>
>     This is the first thing I’ve built like this. Used official
>     documentation from the website.
>
>     Not sure where to go next for troubleshooting. Rebuild? I hope
>     not. Any advice appreciated.
>
>     Thanks for any help.
>
>     Sent from Mail <https://go.microsoft.com/fwlink/?LinkId=550986>
>     for Windows 10
>



---
This email has been checked for viruses by Avast antivirus software.
https://www.avast.com/antivirus

Mime
View raw message