guacamole-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ivanmarcus <ivanmar...@yahoo.com>
Subject Re: SSH issue with Ubuntu 18.04 - updated detail
Date Mon, 13 Aug 2018 20:41:49 GMT
libssl-dev is the one.

Earlier I'd discovered that the directory paths between 16.04 and 18.04 
were quite different for some installed packages. If I put in some 
symbolic links it fixed some of the 'missing' issues, but it seemed like 
a long process and I'm sure there's a better way!

Anyway libssl-dev was the final step to getting it to compile with ssl, 
but still no recognised libssh2 (despite it being in place), nor pango 
(also in place).

FWIW the install to date wasn't easy, had to go looking for some 
packages in odd places and we're still not working. I expect just adding 
the repository and installing from there would be much more 
straightforward (?) but I guess that won't sort out the issues with this 
script and Nate's lack of ssh...


On 13/08/2018 10:45 p.m., Nick Couchman wrote:
>
>
> On Sun, Aug 12, 2018 at 22:19 ivanmarcus <ivanmarcus@yahoo.com 
> <mailto:ivanmarcus@yahoo.com>> wrote:
>
>
>     checking openssl/ssl.h usability... no
>     checking openssl/ssl.h presence... no
>     checking for openssl/ssl.h... no
>     checking for SSL_CTX_new in -lssl... no
>     configure: WARNING:
>       --------------------------------------------
>        Unable to find libssl.
>        guacd will not support SSL connections.
>       --------------------------------------------
>
>
> Looks like maybe the OpenSSL development package is missing?  I can't 
> remember what it is on Ubuntu, but probably something like libssl-dev 
> or openssl-dev or something like that?
>
> If I have a chance today I'll spin up that version and see what I can 
> figure out.
>
> -Nick


Mime
View raw message