guacamole-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From wouterve <woutervanee...@avr.be>
Subject Using HTTPS with apache leads to 500:internal error
Date Mon, 27 Aug 2018 07:32:03 GMT
Hi,
I'm trying to implement https with my guacamole-server but thus far I only
get a blank page. 
In the developer tools I got serveral errors with status code 500 while
trying to load .js files.

ET 
https://www.example.com/guacamole/app.css [HTTP/1.1 500 Internal Error
291ms]
GET 
https://www.example.com/guacamole/relocateParameters.js [HTTP/1.1 500
Internal Error 6417ms]
GET 
https://www.example.com/guacamole/webjars/jquery/2.1.3/dist/jquery.min.js
[HTTP/1.1 500 Internal Error 1927ms]
GET 
https://www.example.com/guacamole/webjars/lodash/2.4.1/dist/lodash.min.js
[HTTP/1.1 500 Internal Error 3516ms]
GET 
https://www.example.com/guacamole/webjars/angular/1.3.16/angular.min.js
[HTTP/1.1 500 Internal Error 1825ms]
GET 
https://www.example.com/guacamole/webjars/angular-cookies/1.3.16/angular-cookies.min.js
[HTTP/1.1 500 Internal Error 3385ms]
GET 
https://www.example.com/guacamole/webjars/angular-route/1.3.16/angular-route.min.js
[HTTP/1.1 500 Internal Error 3296ms]
GET 
https://www.example.com/guacamole/webjars/angular-touch/1.3.16/angular-touch.min.js
[HTTP/1.1 500 Internal Error 1728ms]
GET 
https://www.example.com/guacamole/webjars/messageformat/1.0.2/messageformat.min.js
[HTTP/1.1 500 Internal Error 4574ms]
GET 
https://www.example.com/guacamole/webjars/angular-translate/2.8.0/angular-translate.min.js
[HTTP/1.1 500 Internal Error 1818ms]
GET 
https://www.example.com/guacamole/webjars/angular-translate-interpolation-messageformat/2.8.0/angular-translate-interpolation-messageformat.min.js
[HTTP/1.1 500 Internal Error 3356ms]
GET 
https://www.example.com/guacamole/webjars/angular-translate-loader-static-files/2.8.0/angular-translate-loader-static-files.min.js
[HTTP/1.1 500 Internal Error 3793ms]
GET 
https://www.example.com/guacamole/webjars/blob-polyfill/1.0.20150320/Blob.js
[HTTP/1.1 500 Internal Error 5409ms]
GET 
https://www.example.com/guacamole/webjars/filesaver/1.3.3/FileSaver.min.js
[HTTP/1.1 500 Internal Error 3645ms]
GET 
https://www.example.com/guacamole/webjars/angular-module-shim/0.0.4/angular-module-shim.js


The response of each is empty.

I've modified my <virtualhost *:443>  to include a proxy for the websocket
tunnel:




<Location /guacamole/>
    Order allow,deny
    Allow from all
    ProxyPass http://localhost:8080/guacamole/ flushpackets=on
    ProxyPassReverse http://localhost:8080/guacamole/
</Location>

<Location /guacamole/websocket-tunnel>
    Order allow,deny
    Allow from all
    ProxyPass ws://localhost:8080/guacamole/websocket-tunnel
    ProxyPassReverse ws://localhost:8080/guacamole/websocket-tunnel
</Location>

as indicated on 
https://guacamole.apache.org/doc/gug/proxying-guacamole.html
<https://guacamole.apache.org/doc/gug/proxying-guacamole.html>  

What could be the cause of my problem?

kr
wouter




--
Sent from: http://apache-guacamole-general-user-mailing-list.2363388.n4.nabble.com/

Mime
View raw message