guacamole-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ivanmarcus <ivanmar...@yahoo.com>
Subject Re: SSH issue with Ubuntu 18.04
Date Sun, 12 Aug 2018 20:17:05 GMT
Not sure if it helps but I just ran up a bare 18.04 VM, installed MySQL 
and tried that script. I note the install has a working ssh client already.

The script gave me an error saying that libssh2-1-dev is not available 
etc, and it fails. There were other errors too but that's probably the 
most pertinent.

That suggests to me there's something in the script that's looking for a 
specific version of ssh and failing when it can't find it. I've not 
looked at the script (no expert here) but perhaps it's worth 
investigating that and modifying as needed to suit 18.04?

Cheers.


On 13/08/2018 6:39 a.m., Nate Evans wrote:
> I've got these two packages for libssh installed
>
> libssh2-1/bionic,now 1.8.0-1 amd64 [installed]
> libssh2-1-dev/bionic,now 1.8.0-1 amd64 [installed]
>
> As for the version of guacd I installed Guacamole 0.9.14 using the 
> MysticRyuujin install script here is a link to it. 
> https://github.com/MysticRyuujin/guac-install
>
> I've installed this successfully before without issue, but I did a new 
> OS install and restored guacamole from a backup and it's had issues 
> with ssh ever since. Other protocols work fine, I can RDP into my 
> windows machines without issue it's only the ssh protocol that is 
> having issues.
>
> On Fri, Aug 10, 2018 at 11:26 AM Nick Couchman <vnick@apache.org 
> <mailto:vnick@apache.org>> wrote:
>
>
>
>     On Thu, Aug 9, 2018 at 3:07 PM Nate Evans <nate479@gmail.com
>     <mailto:nate479@gmail.com>> wrote:
>
>         I'm having an issue connecting to my linux server using SSH in
>         guacamole, RDP works fine but when I try to ssh to my machine
>         it attempts then times out.
>
>         catalina.out has this error
>
>         [http-nio-8080-exec-5] ERROR
>         o.a.g.s.GuacamoleHTTPTunnelServlet - HTTP tunnel request
>         failed: Connection to guacd timed out.
>
>         Syslog has this error
>
>         guacd[4235]: Creating new client for protocol "ssh"
>         guacd[25016]: Support for protocol "ssh" is not installed
>
>         The required ssh libraries are installed, and I'm at a loss as
>         to why I can't ssh into my server, Can anyone help with this
>         issue?
>
>
>     Did you install the libssh2-dev package?  Also, what version of
>     guacd are you installing, and how are you installing it?
>
>     -Nick
>


Mime
View raw message