On Mon, Jul 9, 2018 at 9:07 AM tanon <loic@v2cloud.com> wrote:
Hi,
Thank you for your reply.
Here is the json containing the parameter:
{
    "username" : "User1",
    "connections" : {
        "connection1" : {
            "protocol" : "rdp",
            "parameters" : {
                "hostname" : "xxx.xxx.xxxx.xxx",
                "password" : "xxx",
                "port" : "3389",
                "username" : "Administrator",
                "domain" : "DOMAIN",
                "ignore-cert" : "true",
                "color-depth": "16",
                "security": "rdp"
            }
        }
    }}

When I use "nla" as security, I get the same error:

guacd[1894]: INFO:      Last user of connection
"$0b70182e-68c2-4b36-a472-26d71bc159ad" disconnected
connected to 169.254.215.146:3389
SSL_read: Failure in SSL library (protocol error?)
guacd[1]: INFO: Connection "$0b70182e-68c2-4b36-a472-26d71bc159ad" removed.

using tls or rdp:

connected to 169.254.215.146:3389
Error: protocol security negotiation failure
guacd[1]: INFO: Connection "$0d28e3c2-90a6-41f7-9b3d-acbdb6c838e3" removed.


I recently ran into a similar error and it turned out to be an issue with FreeRDP 1.1.0.  I upgraded FreeRDP in my CentOS environment to 1.2.0 (unreleased, from Github), and it worked fine.  The 1.0.0 release, which is being actively worked, now, will actually transition the Docker image away from CentOS and over to Debian stable, so that may help with this issue.  You can try out the current 1.0.0 code by checking it out from Github and building the Docker images, there, if you like, or you can wait until 1.0.0 is released.

-Nick