guacamole-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nick Couchman <vn...@apache.org>
Subject Re: Guacd 0.9.14 inside a docker: Not able to connect to windows
Date Fri, 06 Jul 2018 18:54:08 GMT
On Fri, Jul 6, 2018 at 1:16 PM tanon <loic@v2cloud.com> wrote:

> Hi,
> I got this error message from guacd docker logs when try to open a
> connection:
>
> guacd[1]: INFO: Connection ID is "$d569c7b5-6b45-4706-a605-681f9639dd14"
> guacd[20]: DEBUG:       Parameter "console" omitted. Using default value of 0.
> guacd[20]: DEBUG:       Parameter "console-audio" omitted. Using default value of 0.
> guacd[20]: DEBUG:       Parameter "disable-auth" omitted. Using default value of 0.
> guacd[20]: INFO:        Security mode: ANY
> guacd[20]: DEBUG:       User resolution is 1107x858 at 96 DPI
> guacd[20]: DEBUG:       Parameter "dpi" omitted. Using default value of 96.
> guacd[20]: DEBUG:       Using resolution of 1104x858 at 96 DPI
> guacd[20]: DEBUG:       Parameter "read-only" omitted. Using default value of 0.
> guacd[20]: DEBUG:       Parameter "enable-font-smoothing" omitted. Using default value
of 0.
> guacd[20]: DEBUG:       Parameter "enable-full-window-drag" omitted. Using default value
of 0.
> guacd[20]: DEBUG:       Parameter "enable-desktop-composition" omitted. Using default
value of 0.
> guacd[20]: DEBUG:       Parameter "enable-menu-animations" omitted. Using default value
of 0.
> guacd[20]: DEBUG:       Parameter "disable-audio" omitted. Using default value of 0.
> guacd[20]: DEBUG:       Parameter "create-drive-path" omitted. Using default value of
0.
> guacd[20]: DEBUG:       Parameter "enable-sftp" omitted. Using default value of 0.
> guacd[20]: DEBUG:       Parameter "sftp-hostname" omitted. Using default value of "169.254.215.146".
> guacd[20]: DEBUG:       Parameter "sftp-port" omitted. Using default value of "22".
> guacd[20]: DEBUG:       Parameter "sftp-username" omitted. Using default value of "Administrator".
> guacd[20]: DEBUG:       Parameter "sftp-password" omitted. Using default value of "".
> guacd[20]: DEBUG:       Parameter "sftp-passphrase" omitted. Using default value of "".
> guacd[20]: DEBUG:       Parameter "sftp-root-directory" omitted. Using default value
of "/".
> guacd[20]: DEBUG:       Parameter "sftp-server-alive-interval" omitted. Using default
value of 0.
> guacd[20]: DEBUG:       Parameter "recording-name" omitted. Using default value of "recording".
> guacd[20]: DEBUG:       Parameter "create-recording-path" omitted. Using default value
of 0.
> guacd[20]: INFO:        Resize method: reconnect
> guacd[20]: DEBUG:       Parameter "enable-audio-input" omitted. Using default value of
0.
> guacd[20]: INFO:        User "@130c35bb-faa8-4b30-a88b-4db6e310962e" joined connection
"$d569c7b5-6b45-4706-a605-681f9639dd14" (1 users now present)
> guacd[20]: INFO:        Loading keymap "base"
> guacd[20]: INFO:        Loading keymap "en-us-qwerty"
> guacd[20]: ERROR:       Error connecting to RDP server
> guacd[20]: INFO:        User "@130c35bb-faa8-4b30-a88b-4db6e310962e" disconnected (0
users remain)
> guacd[20]: INFO:        Last user of connection "$d569c7b5-6b45-4706-a605-681f9639dd14"
disconnected
> connected to 169.254.215.146:3389
> SSL_read: Failure in SSL library (protocol error?)
> guacd[1]: INFO: Connection "$d569c7b5-6b45-4706-a605-681f9639dd14" removed.
>
>
> I double checked the credentials and they are valid.
> Is anyone can suggest me where I can start troubleshooting?
>
>
Might want to try adjusting the security between RDP, TLS, and NLA, and see
if that helps?  Almost looks like it is trying to use TLS, here (SSL_read
seems TLS-ish), and maybe that's causing problems.  NLA is a pretty safe
bet for recent Windows systems.  Also, try ticking the box marked "Ignore
Server Certificates" (or setting the matching option if you're using
something other than JDBC) and see if that helps.

-Nick

Mime
View raw message