guacamole-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nick Couchman <vn...@apache.org>
Subject Re: Segfault with guacamole 0.9.14
Date Wed, 27 Jun 2018 19:28:53 GMT
>
> What version of the libvncserver/libvncclient are you building against?
>
> # dpkg -l | grep vncclient
> ii libvncclient1:amd64 0.9.11+dfsg-1+deb9u1 amd64 API to write one's own
> VNC server - client library
>

Hmmm....I can't remember if there are any version-specific issues with that
version of libvncclient, but I'd expect the segfault message to happen in
libvncclient not the Guacamole library, if that were the case.


> Any special configuration for VNC?
>
> for the client, this is nothing special
>
> Are you trying to use encryption?
>
> No encryption
>
> no password, trought reverse ssh with ssh-key without passphrase
>
> Jun 27 16:10:34 pulsemaster kernel: [717204.421339] guacd[28944]: segfault
> at 10 ip 00007f9ead26c692 sp 00007f9eaec7ad10 error 4 in
> libguac-client-vnc.so.0.0.0[7f9ead264000+13000]
>
At this point I'd probably need a core dump or gdb stack trace to track
down the issue.

You can see if any of the following issues match the scenario you're
running into:
https://issues.apache.org/jira/browse/GUACAMOLE-424
https://issues.apache.org/jira/browse/GUACAMOLE-428

Those issues are related - one deals with VNC password issues, but it looks
like the fix takes care of at least a couple of scenarios.  It looks like
that's not fixed in the 0.9.14 code but will be in the 1.0.0 code, so you
could try building guacd from the git repo, either the master branch or the
staging/1.0.0 branch.

-Nick

Mime
View raw message