guacamole-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Richert Jérémy <jeremy.rich...@arte.tv>
Subject RE: Cannot connect to RDS Broker
Date Mon, 05 Mar 2018 16:31:57 GMT
Hi,

Thanks for the quick answer.
Unfortunately, with the patched FreeRDP, the issue is worse: I cannot connect to any RDP server,
even without a broker.
Guacamole just tries to connect for a long time then fails.
The FreeRDP executable is working however.

I think we will have to remove the RDS broker for now and wait for a FreeRDP / Guacamole version
that supports it.

Thanks for you help.

Best regards,
Jeremy Richert

De : Nick Couchman [mailto:vnick@apache.org]
Envoyé : jeudi 1 mars 2018 11:56
À : user@guacamole.apache.org
Objet : Re: Cannot connect to RDS Broker

On Thu, Mar 1, 2018 at 5:52 AM, Nick Couchman <vnick@apache.org<mailto:vnick@apache.org>>
wrote:
On Thu, Mar 1, 2018 at 5:28 AM, Richert Jérémy <jeremy.richert@arte.tv<mailto:jeremy.richert@arte.tv>>
wrote:
Hi,

We are currently using Guacamole 0.9.12 to connect to RDS servers and it works great.

However, we will soon add a RDS broker server, and I can’t get Guacamole to connect on this
broker.
I have read that RDS brokers were only supported with FreeRDP 1.1+, so I have tried setting
up a Guacamole 0.9.14 compiled with FreeRDP 1.1.

Using only FreeRDP with the following command line, the connection is successful:
xfreerdp /cert-ignore /v:172.25.xxx.xxx /d:MY_DOMAIN /u:user /p:password /load-balance-info:"tsv://MS
Terminal Services Plugin.1.BUREAU"

But with the same configuration in Guacamole, I just get rejected by the server:

<config name="RDS broker" protocol="rdp">
                <param name="domain" value="MY_DOMAIN" />
                <param name="username" value="user" />
                <param name="password" value="password" />
                <param name="hostname" value="172.25.xxx.xxx" />
                <param name="ignore-cert" value="true" />
                <param name="load-balance-info" value="tsv://MS Terminal Services Plugin.1.BUREAU"
/>
</config>


There's a JIRA issue out there that currently deals with this:

https://issues.apache.org/jira/projects/GUACAMOLE/issues/GUACAMOLE-370

Also, this one:

https://issues.apache.org/jira/browse/GUACAMOLE-40

I'm not sure the stable-1.1 branch actually works correctly - it looks like you need 1.1 with
a few patches.

-Nick


Click here<https://www.mailcontrol.com/sr/vxujoylPr8PGX2PQPOmvUs3i7gRn49HgzsRNaeOJ3XQdGuGlg5k64l+4vBHNiqSrgGRbEKz7KwXCXaTERp6oIw==>
to report this email as spam.
Mime
View raw message