guacamole-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nick Couchman <vn...@apache.org>
Subject Re: Cannot connect to RDS Broker
Date Thu, 01 Mar 2018 10:56:01 GMT
On Thu, Mar 1, 2018 at 5:52 AM, Nick Couchman <vnick@apache.org> wrote:

> On Thu, Mar 1, 2018 at 5:28 AM, Richert Jérémy <jeremy.richert@arte.tv>
> wrote:
>
>> Hi,
>>
>>
>>
>> We are currently using Guacamole 0.9.12 to connect to RDS servers and it
>> works great.
>>
>>
>>
>> However, we will soon add a RDS broker server, and I can’t get Guacamole
>> to connect on this broker.
>>
>> I have read that RDS brokers were only supported with FreeRDP 1.1+, so I
>> have tried setting up a Guacamole 0.9.14 compiled with FreeRDP 1.1.
>>
>>
>>
>> Using only FreeRDP with the following command line, the connection is
>> successful:
>>
>> xfreerdp /cert-ignore /v:172.25.xxx.xxx /d:MY_DOMAIN /u:user /p:password
>> /load-balance-info:"tsv://MS Terminal Services Plugin.1.BUREAU"
>>
>>
>>
>> But with the same configuration in Guacamole, I just get rejected by the
>> server:
>>
>>
>>
>> <config name="RDS broker" protocol="rdp">
>>
>>                 <param name="domain" value="MY_DOMAIN" />
>>
>>                 <param name="username" value="user" />
>>
>>                 <param name="password" value="password" />
>>
>>                 <param name="hostname" value="172.25.xxx.xxx" />
>>
>>                 <param name="ignore-cert" value="true" />
>>
>>                 <param name="load-balance-info" value="tsv://MS Terminal
>> Services Plugin.1.BUREAU" />
>>
>> </config>
>>
>>
>>
>
> There's a JIRA issue out there that currently deals with this:
>
> https://issues.apache.org/jira/projects/GUACAMOLE/issues/GUACAMOLE-370
>

Also, this one:

https://issues.apache.org/jira/browse/GUACAMOLE-40

I'm not sure the stable-1.1 branch actually works correctly - it looks like
you need 1.1 with a few patches.

-Nick

Mime
View raw message