guacamole-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nick Couchman <vn...@apache.org>
Subject Re: Getting error while connecting to Windows 10 [ NLA disabled ]
Date Sun, 07 Jan 2018 13:49:44 GMT
On Sun, Jan 7, 2018 at 12:07 AM, Amarjeet Singh <amarjeetxc@gmail.com>
wrote:

>
>
> Connection error  on Web Interface  is as follows :-
>
> *The remote desktop server is currently unreachable. If the problem
>> persists, please notify your system administrator, or check your system
>> logs.    Reconnecting in 4 seconds...*
>
>
>
> Screenshot :
>
> [image: Inline image 1]
>
>
> Configuration in user-mapping.xml File :-
>
>   <authorize username="jasbir.singh" password="xyz@123">
>>                  <connection name="Windows Server 2012 R2 Jasbir Singh">
>>                         <protocol>rdp</protocol>
>>                         <param name="hostname">172.17.1.75</param>
>>                         <param name="port">3389</param>
>>                         <param name="resize-method">display-u
>> pdate</param>
>>                         <param name="enable-printing">true</param>
>>                         <param name="create-drive-path">true</param>
>>                         <param name="enable-drive">true</param>
>>                         <param name="drive-path">/tmp/${GUAC_
>> USERNAME}</param>
>>                         <param name="ignore-cert">true</param>
>>                         <param name="security">any</param>
>>                         <param name="domain">ucalo.com</param>
>>                         <param name="static-channels">hyprint</param>
>>                         <param name="username">Jasbir Singh</param>
>>                         <param name="password">Sunny@28*Manny</param>
>>                 </connection>
>>          </authorize>
>
>
>
> Machine is not in the domain of  *ucalo.com <http://ucalo.com> *instead
> it should be *localhost .*
>
> *but* further debugging I got to know that if domain name is incorrect {
> ucalo.com or ucal.com or whatever } it will login into the Machine only
> if username and password is correct and domain is localhost.
>
> Unit Case 1 : If username is incorrect it will show the above error.
>
> Unit Case 2 : If username is correct and password is incorrect , it will
> show the above error.
>
>
If you're using Guacamole 0.9.13-incubating, you may be hitting an issue
that I believe is resolved in the upcoming 0.9.14 release with RDP
connections not throwing correct errors.  Obviously if the username,
password, or domain is incorrect you should get an error message about
invalid credentials, not something about the sever being unreachable.  This
fix should be in the current git repos and should be present in 0.9.14 when
it is released.

-Nick

Mime
View raw message