guacamole-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Greg Trasuk <tras...@stratuscom.com>
Subject Re: Performance issues guacamole 0.9.13
Date Wed, 13 Dec 2017 15:53:37 GMT
Looking at the docs, it appears that the Guac manual says exactly the opposite of what I said.
 It may make a difference that in my setup I have both proxy statements inside the a virtualhost
element, with no <Location> elements.  So you should probably ignore my previous suggestion.

Cheers,

Greg Trasuk

> On Dec 13, 2017, at 10:50 AM, Greg Trasuk <trasukg@stratuscom.com> wrote:
> 
> Try reversing the order of the <Location> elements so that the websocket proxy
statements appear first.  Otherwise the non-ws proxy gets selected.
> 
> Cheers,
> 
> Greg Trasuk
> 
>> On Dec 13, 2017, at 10:07 AM, wouterve <woutervaneenoo@avr.be> wrote:
>> 
>> So, I've followed the instruction from the guacamole documentation.
>> 
>> This is what i've done
>> 
>> 1-installed apache2 through apt
>> 2-Added following lines to /etc/apache2/apache2.conf:
>> 
>> <Location /guacamole/>
>>   Order allow,deny
>>   Allow from all
>>   ProxyPass http://HOSTNAME:8080/guacamole/ flushpackets=on
>>   ProxyPassReverse http://HOSTNAME:8080/guacamole/
>> </Location>
>> 
>> <Location /guacamole/websocket-tunnel>
>>   Order allow,deny
>>   Allow from all
>>   ProxyPass ws://HOSTNAME:8080/guacamole/websocket-tunnel
>>   ProxyPassReverse ws://HOSTNAME:8080/guacamole/websocket-tunnel
>> </Location>
>> 
>> 
>> of course, changing HOSTNAME with the IP-adress of my server
>> 
>> 3 - Added this line in /etc/guacamole/guacamole.properties
>> 
>> enable-websocket: true
>> 
>> 4-finally rebooted the guacamole server to make sure everyting is active.
>> 
>> Still no luck though:
>> 
>> 17:06:13.912 [http-bio-8080-exec-10] INFO 
>> o.a.g.r.auth.AuthenticationService - User "guacadmin" successfully
>> authenticated from <ip-address>.
>> 17:06:14.748 [http-bio-8080-exec-1] INFO  o.a.g.tunnel.TunnelRequestService
>> - User "guacadmin" connected to connection "1".
>> 17:06:14.752 [http-bio-8080-exec-1] INFO  o.a.g.tunnel.TunnelRequestService
>> - User "guacadmin" disconnected from connection "1". Duration: 3
>> milliseconds
>> 17:06:15.052 [http-bio-8080-exec-9] INFO  o.a.g.tunnel.TunnelRequestService
>> - User "guacadmin" connected to connection "1".
>> 17:06:15.052 [http-bio-8080-exec-9] INFO 
>> o.a.g.t.h.RestrictedGuacamoleHTTPTunnelServlet - Using HTTP tunnel (not
>> WebSocket). Performance may be sub-optimal.
>> 
>> 
>> What did I overlook?
>> 
>> kr,
>> 
>> wouter
>> 
>> 
>> 
>> 
>> --
>> Sent from: http://apache-guacamole-general-user-mailing-list.2363388.n4.nabble.com/
> 


Mime
View raw message