guacamole-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From wouterve <woutervanee...@avr.be>
Subject Performance issues guacamole 0.9.13
Date Fri, 08 Dec 2017 13:46:33 GMT
I'm having a hard time getting guacamole 0.9.13 to perform well. The overall
response is really slow, both with VNC as well with RDP. I'm connected
through the LAN. 
Here is my setup

-Xubuntu 16.04 LTS
-Guacamole 0.9.13 with MySQL (installed through  this
<https://github.com/MysticRyuujin/guac-install/blob/master/guac-install.sh>  
script)
-Tigervncserver 1.8.0 

When I open the connection in the browser, there is much lag between the
inputs and the response. Clicking a button will only result in opening the
menu after 1-2 seconds. Also, I often loose connection and have to
reconnect.
 I've made a comparison  video <https://youtu.be/oIndQq4El3k>  . 

According to  this
<http://apache-guacamole-general-user-mailing-list.2363388.n4.nabble.com/Guacamole-0-9-12-WAN-Performance-Ubuntu-14-XDRP-tp1040p1043.html>
 
post the cause could be that websockets are not working. 
When opening up a connection and moving window screen as suggested, I do see
CPU peaks from guacd and XVNC as well (50% and more). 
I haven't figereud out how to debug the connection yet to determine the
protocol yet (as the second suggestion mentions)


Now my question:
How can I improve my performance? Could it be caused by not using websockets
and if so, how can I implement this (I'm not verry acquainted to this yet).

kind regards,

wouter



--
Sent from: http://apache-guacamole-general-user-mailing-list.2363388.n4.nabble.com/

Mime
View raw message