guacamole-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lars van Ruiten" <l.van.rui...@praxis-automation.nl>
Subject RE: SFTP problems
Date Mon, 13 Nov 2017 13:55:17 GMT
Thank you for your quick reply.

 

Both guacamole webapp and guacd are 0.9.12-incubating. (Just confirmed with syslog)

No, I have not tried 0.9.13-incubating, and I would prefer not to do the upgrade at this moment.

 

Also I am not entirely sure when the problems started, I have updated to 0.9.12 5 months ago,
and although most of the files that are uploaded to the remote stations are under 10kb, it
seems unlikely that no one ever uploaded something bigger before today.

 

The webapp shows the error as you can see in my original mail, but both syslog and Catalina.out
don’t show any errors related to SFTP stuff.

 

Kind regards,

Lars van Ruiten

 

From: Nick Couchman [mailto:vnick@apache.org] 
Sent: Monday, November 13, 2017 2:07 PM
To: user@guacamole.incubator.apache.org
Subject: Re: SFTP problems

 

On Mon, Nov 13, 2017 at 7:51 AM, Lars van Ruiten <l.van.ruiten@praxis-automation.nl <mailto:l.van.ruiten@praxis-automation.nl>
> wrote:

Hello all,

 

Since upgrading Guacamole to 0.9.12-incubating (from 0.9.8), users have reported issues uploading
files over SFTP connections (Added to a VNC connection).

It appears that any file larger than ~1MB will not upload, but give a permission related error.
(See screenshot)

Uploading the file to the SFTP server directly with Bitvise SFTP client works fine.

 

To me it sounds like if a file is larger than a certain size, guacd will buffer it on the
disk on the server and it does not have the permission to do that. (The disk is not full)

It happens to all connections, and I am sure that with some connections it has worked before,
and the only thing that changed is the newer version of guacamole.

 

If someone has any idea how I can fix this, please let me know. Uploading/downloading files
is one of the most used features in our case.

 

Kind regards

L van Ruiten

 

A couple of quick questions:

- Did you upgrade both the client and the server components of Guacamole to 0.9.12-incubating?

- Have you tried 0.9.13-incubating?

 

-Nick


Mime
View raw message