guacamole-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ryan Underwood <r...@greymarketlabs.com>
Subject RE: Deploying locally built WAR
Date Fri, 13 Oct 2017 20:19:45 GMT
I can telnet from guacamole to guacd and guacd gives me a protocol error when I do. I literally
copied the scripts a buddy is using on Windows and his works fine.
I added logging to the classes throwing the error to provide more details on what was requested.

Sent from my Android phone using TouchDown (www.symantec.com)

-----Original Message-----
From: Mike Jumper [mike.jumper@guac-dev.org]
Received: Friday, 13 Oct 2017, 4:07PM
To: user@guacamole.incubator.apache.org [user@guacamole.incubator.apache.org]
Subject: Re: Deploying locally built WAR

On Fri, Oct 13, 2017 at 1:00 PM, Ryan Underwood <ryan@greymarketlabs.com<mailto:ryan@greymarketlabs.com>>
wrote:
Thanks Nick – not sure how I missed it in the root.
Now I have the image built from my local repo clone. I’ve modified some of the source to
add logging because I still can’t connect to an RDP instance and the only error I get is:
9:50:16.382 [http-nio-8080-exec-9] ERROR o.a.g.s.GuacamoleHTTPTunnelServlet - HTTP tunnel
request failed: java.net.ConnectException: Connection refused
19:50:16.384 [http-nio-8080-exec-9] DEBUG o.a.g.s.GuacamoleHTTPTunnelServlet - Internal error
in HTTP tunnel.
org.apache.guacamole.GuacamoleServerException: java.net.ConnectException: Connection refused


This looks like guacd is unreachable. Is your Guacamole image configured to connect to a running
copy of guacd (in another Docker container or otherwise)?

This is the same error I get with the docker hub image too.  However, after adding some logging
in the java classes and updating the logback.xml to go to trace, none of my messages show
up anywhere.  Any thoughts?

What logging did you add?

- Mike


Mime
View raw message