guacamole-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ryan Underwood <r...@greymarketlabs.com>
Subject RE: tracking down a tomcat 500 error
Date Thu, 05 Oct 2017 01:52:20 GMT
I thought I was there but think I have a problem with guacamole connecting to guacd.  From
each of the containers I can ping the other so the network connectivity within docker _seems_
OK.  Here’s what I have when I attempt to connect to a connection that I setup through the
GUI:

01:42:10.038 [http-nio-8080-exec-1] ERROR o.a.g.w.GuacamoleWebSocketTunnelEndpoint - Creation
of WebSocket tunnel to guacd failed: java.net.ConnectException: Connection refused (Connection
refused)
01:42:10.108 [http-nio-8080-exec-7] ERROR o.a.g.s.GuacamoleHTTPTunnelServlet - HTTP tunnel
request failed: java.net.ConnectException: Connection refused (Connection refused)

Any tips on this one?  I saw an error like this in the board history but the person said they
didn’t have guacd running.  I know it’s running but perhaps there’s a connectivity issue…
Thank you
-Ryan

From: Ryan Underwood [mailto:ryan@greymarketlabs.com]
Sent: Wednesday, October 04, 2017 9:43 AM
To: user@guacamole.incubator.apache.org
Subject: RE: tracking down a tomcat 500 error

Docker on win10 pro does, and that was a good idea.  I had the password environment variable
wrong and saw the access denied for the user in the mysql logs.  Thanks for the quick responses!

From: Mike Jumper [mailto:mike.jumper@guac-dev.org]
Sent: Wednesday, October 04, 2017 12:17 AM
To: user@guacamole.incubator.apache.org<mailto:user@guacamole.incubator.apache.org>
Subject: Re: tracking down a tomcat 500 error

On Tue, Oct 3, 2017 at 8:42 PM, Ryan Underwood <ryan@greymarketlabs.com<mailto:ryan@greymarketlabs.com>>
wrote:
I am running guacamole via docker on win10 pro. I’m using Mysql, guacamole and guacd and
all appear to be running as intended.  I get a 500 error when I hit the home page. Localhost
access log shows all the GETs work

Those GETs are probably to static files, and thus aren't hitting the component which is failing.

and a PUT failed (172.17.0.1 - - [04/Oct/2017:03:27:52 +0000]

There shouldn't be a PUT occurring prior to login. What URL is that PUT request for?

"POST /guacamole/api/tokens HTTP/1.1" 500 185).  Any ideas where I should be looking to narrow
this down or get more info?

".../api/tokens" is the URL of the REST endpoint used for handling authentication. Given the
description of your setup, the MySQL portion of things is most likely misconfigured (somehow).
Once we find the proper log, things should clear up.

  Catalina error seems to be in non-guacamole classes so not sure where to go next.
-Ryan

Catalina:

04-Oct-2017 03:13:40.242 SEVERE [http-nio-8080-exec-8] com.sun.jersey.spi.container.ContainerResponse.logException
Mapped exception to response: 500 (Internal Server Error)
org.apache.guacamole.rest.APIException
        at org.apache.guacamole.rest.RESTExceptionWrapper.invoke(RESTExceptionWrapper.java:202)

What log file is this from specifically?

Thanks,

- Mike

Mime
View raw message