guacamole-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nick Couchman <vn...@apache.org>
Subject Re: Guacamole Install Script problems
Date Tue, 10 Oct 2017 18:21:40 GMT
On Tue, Oct 10, 2017 at 2:14 PM, Carter Sema <CSema@acschools.org> wrote:

> Installed Guacamole from this script several times
> https://sourceforge.net/projects/guacamoleinstallscript/ . Without any
> problems, went to stand up a testing box and its acting like the
> application didn’t install. I navigate to my URL with nginx and without the
> reverse proxy and it just returns 404 errors.
>
> Started the service guacd, tomcat, nginx. Checked some of the
> configuration and everything looks right to me…
>
>
>
> Any Idea’s?
>
> Thanks!
>
> Carter
>
>
>

First, it's worth noting that this install script isn't officially
associated with the Guacamole project.  Looks like someone (Hernan) has
created the script and posted it on SourceForge.  I've never seen/used that
script, so not sure what it does.  It looks like Hernan keeps it up to date
(mostly, as of May), but based on the fact that it is separate from the
project, the amount of support you're going to get from this community for
that script is going to be limited.

That said, in order to debug any issues you're having getting Guacamole to
run, you're going to need to look at configuration files and log files.
The amount of information you've provided isn't very comprehensive, so when
you say you checked some of the configuration and it looks right - what
configurations did you check?  How are they configured?  What messages are
you seeing in the Nginx log files?  How about the Tomcat log files?  Have
you checked to make sure the Guacamole webapp is getting deployed by
Tomcat?  Is it at the URL you expect it to be at?  Is the 404 being thrown
by Nginx or by Tomcat?

Please look at those items and provide additional detail, and we'll see
what we can do to help you get it going.

Regards,
Nick

Mime
View raw message