guacamole-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Sten <iam.erics...@gmail.com>
Subject Re: Websocket tunnel connection time out issues
Date Mon, 11 Sep 2017 22:42:45 GMT
Nick, Mike:

  Can you explain how to attach gdb to the guard process?  I tried running
the following (based on some searching on the net):

gdb —args /usr/local/sbin/guacd -L debug -f

which then brought up the gdb console where I entered “run”.

I got a bunch of messages stating that no debugging symbols were found and
when I tried connecting to guacamole I got the same level of logging as
before.

I suspect I am running the correct command but I don’t believe I have
debugging compiled into guacd.  What would be the proper way to compile
guacd with debugging?  My experience is limited to running make, make
install and make clean, when it comes to compiling programs. :-)

Thanks

   Eric Sten


-- 
Eric Sten
Visit Trixies Tales, adventures of a domestic dog. — www.trixiestales.com

On September 10, 2017 at 8:33:02 PM, vnick (vnick@apache.org) wrote:

EricSten wrote
> Nick,
>
> I’m guessing you tried to attach an image of some sort to your last
> email
> but it didn’t show up. When I run a “make" on the guacamole-server 0.9.13
> this is what I get at the end of the script run…
> ...

Yeah, I had tried to use the code tag on Nabble, which apparently the
Apache
list server stripped out. The configure output you posted looks fine to me,
so not sure what's going on there.

As Mike suggested, it might be good to try to attach gdb to the guacd
process and gather the output during one of the connection attempts. I
think you'll need to run it with the -f option to capture forked processes,
and you can also use -o to specify an output file so that it doesn't just
spew it all over the terminal. I'd be happy to do it myself, but since I
can't reproduce it, that's not going to help much.

-Nick



-- 
Sent from: http://apache-guacamole-incubating-users.2363388.n4.nabble.com/

Mime
View raw message