guacamole-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Sten <iam.erics...@gmail.com>
Subject Re: Issues with mysql/mariadb authentication
Date Thu, 21 Sep 2017 01:03:23 GMT
Mike, Nick.

 After turning SELinux back on I found that the mysql_connect_any setting
is OFF when I ran a getsebool -a | grep mysql.  After setting it to be on
with the *setsebool mysql_connect_any 1 *I am able to authenticate into
Guacamole using mysql without errors and with SELinux enabled.

In case it helps the CentOS I installed is from the
CentOS-7-x86_64-Minimal-1708.iso.  I downloaded it on 9/16.

  Thanks again for the assistance from both of you.

Eric Sten

-- 
Eric Sten
Visit Trixies Tales, adventures of a domestic dog. — www.trixiestales.com

On September 19, 2017 at 10:34:04 PM, Mike Jumper (mike.jumper@guac-dev.org)
wrote:

On Tue, Sep 19, 2017 at 7:29 PM, Eric Sten <iam.ericsten@gmail.com> wrote:

> Nick,
>
>   That was exactly the issue!  Once I disabled SELinux and rebooted the
> database authentication worked like a charm!
>

Interesting - I've never encountered this on all the CentOS + SELinux
deployments I've dealt with thus far. Mind reporting back when you
determine what setsebool, etc. is necessary to allow things to work
properly with SELinux enabled?

Thanks,

- Mike

Mime
View raw message