guacamole-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike Jumper <mike.jum...@guac-dev.org>
Subject Re: guacamole server 0.9.12-incubating does not compile after upgrading debian jessie to debian stretch
Date Mon, 31 Jul 2017 20:49:24 GMT
On Mon, Jul 31, 2017 at 1:34 PM, Valentin BRICE <dev@vbrice.fr> wrote:

> Hi Daniel,
>
> If I may, you issue here a common compilation error. It seems that the
> flag -Werror as been set in the Makefile. You may suppress the error
> removing the flag in the Makefile.
>
>
As a matter of practice, I strongly advise against ignoring the warnings.
In this case, those functions deal with threadsafety, so the fact that
they're turning up unused with your version of OpenSSL doesn't necessarily
mean it's safe to leave them out, even if the compiler wouldn't normally
consider that an error.

This particular issue should be fixed on master and in 0.9.13-incubating:

https://issues.apache.org/jira/browse/GUACAMOLE-205

I suggest instead waiting for the 0.9.13-incubating release to be announced
and published. It should be soon.

- Mike

Mime
View raw message