guacamole-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paulo Gonçalves <pafgoncal...@ipc.pt>
Subject Re: AW: AW: problem with rdp
Date Mon, 03 Jul 2017 09:06:57 GMT
 

Try setting "security=tls" or "security=any" and "ignore-cert=true". 

Check a previous message about this: 

On Fri, Apr 28, 2017 at 9:34 AM, Suncatcher16 <suncatcher16@outlook.com>
wrote: 

>> Waht type of host do you access ?
>> If its a windows8 or win10 machine (also server 2012 to 2016) you'll have
>> to enable tls security on the connection property in guacamole
>> I also got this error in case the gucamole (guacd) cannot do DNS
>> resolution then setting the IP address instead of FQDN solved that for me
>> 
>> rg
>> Christian
> 
> No, that didn't help.

In addition to TLS, as Christian suggests, you may also need to
configure the connection to ignore the certificate, as the certificate
of your RDP server is likely self-signed. 

> My host is Win8.1 Pro. And why I don't see anything
> reasonable in log alike "authentication failed" or "security level not
> supported"?

Unfortunately, while this sort of thing is possible with the libraries
we use for VNC (libvncclient), SSH (libssh2), and telnet (libtelnet),
the FreeRDP API simply doesn't provide hooks for that sort of
information. Applications which consume the FreeRDP library (like
Guacamole) can obtain the disconnect reason sent from the RDP server in
the form of an error code, and there's been recent work to expose that
information, but that wouldn't help you here. The true details
surrounding why a connection has failed are only logged internally by
FreeRDP. 

For sake of debugging, it can be helpful to try running guacd in the
foreground using the "-f" option (you'll need to kill any existing guacd
processes first). That will allow you to see FreeRDP's internal log
messages, which it sends to STDOUT / STDERR. 

> Only such clutter as "Connection ID is "$42bb300e-fac7-4d"? My logging level in logback.xml
is set to *warn*.

The "logback.xml" file only controls the logging of the web application.
The message above is actually logged by guacd. It's not clutter, but if
you don't want those kinds of messages to be logged, you'll need to
configure guacd's log level, as well, which defaults to "info": 

http://guacamole.incubator.apache.org/doc/gug/configuring-guacamole.html#guacd.conf
[4] 

That said, since you're currently debugging the behavior of a
connection, I don't recommend reducing the verbosity of your logs at
this time. 

- Mike 

---

DTIC - Departamento de Tecnologias de Informação e Comunicação
INSTITUTO POLITÉCNICO DE COIMBRA | Serviços da Presidência
VOIP: 301103

Em 2017-07-03 09:54, Tobias.Wolf@t-systems.com escreveu: 

> The guacamole machine is Linux Ubuntu 16.4 and the remote machine I want to connect to
is a Windows 10. I`m using no explicit defined encryption, I think the standard rdp one is
then being used. 
> 
> VON: brian mullan [mailto:bmullan.mail@gmail.com] 
> GESENDET: Montag, 3. Juli 2017 10:52
> AN: user@guacamole.incubator.apache.org
> BETREFF: Re: AW: problem with rdp 
> 
> Tobias 
> 
> Couple questions 
> 
> What is the remote machine windows or linux 
> 
> What encryption are you using 
> 
> On Jul 3, 2017 3:10 AM, <Tobias.Wolf@t-systems.com> wrote: 
> 
> I`ve a machine with guacamole and a remote machine I want to connect to via RDP. I already
tried from the guacamole machine to connect to the rdp remote machine with freerdp (under
xwindow) only and this is working. Therefore I was thinking it could`nt be a problem with
firewall etc. I`m using the freerdp version which comes with Ubuntu 16.4. I also tried to
compile the latest freerdp version from git, but I got the same result with guacamole. Is
there a way to extend the guacd logging to see what the problem is? 
> 
> mit freundlichen Grüßen 
> 
> Tobias Wolf 
> 
> T-Systems International GmbH 
> 
> GDU Horizontal Solutions 
> 
> Tobias Wolf 
> 
> Software Architekt 
> 
> Project Center ECM & ECM Strategy & Architecture Consulting 
> 
> Dachauer Str. 651, D-80995 München 
> 
> +49 89 54550 - 2479 [1] (Tel.) 
> 
> +49 151 168 80 221 [2] (Mobil) 
> 
> E-Mail: tobias.wolf@t-systems.com 
> 
> Internet: http://www.t-systems.com [3] 
> 
> T-Systems International GmbH 
> 
> Supervisory Board: Thomas Dannenfeldt (Chairman) 
> 
> Board of Management: Reinhard Clemens (Chairman), Dr. Ferri Abolhassan, Dr. Markus Müller,
Georg Pepping, Hagen Rickmann, Klaus Werner 
> 
> Commercial register: Amtsgericht Frankfurt am Main HRB 55933 
> 
> Registered office: Frankfurt am Main 
> 
> Notice: This transmittal and/or attachments may be privileged or confidential. It is
intended solely for the addressee named above. Any review, dissemination, or copying is strictly
prohibited. If you received this transmittal in error, please notify us immediately by reply
and immediately delete this message and all its attachments. Thank you. 
> 
> Big changes start small - conserve resources by not printing every e-mail. 
> 
> VON: Mike Jumper [mailto:mike.jumper@guac-dev.org] 
> GESENDET: Sonntag, 2. Juli 2017 21:28 
> 
> AN: user@guacamole.incubator.apache.org
> BETREFF: Re: problem with rdp 
> 
> On Fri, Jun 30, 2017 at 3:45 AM, <Tobias.Wolf@t-systems.com> wrote: 
> 
> I started from the same machine a rdp session with freerdp successfully. 
> 
> By "same machine", do you mean the machine hosting RDP, the machine hosting Guacamole,
or the machine you're using to connect to Guacamole with a web browser? 
> 
> - Mike
 

Links:
------
[1] tel:+49%2089%20545502479
[2] tel:+49%201511%206880221
[3] http://www.t-systems.com/
[4]
http://guacamole.incubator.apache.org/doc/gug/configuring-guacamole.html#guacd.conf
Mime
View raw message