guacamole-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "McRoy, Jeffrey (GE Healthcare)" <Jeffrey.Mc...@ge.com>
Subject Re: RDP Library not being found
Date Fri, 09 Jun 2017 22:23:04 GMT
Hi Alex,

You are correct, /usr/local/lib/libguac-client-rdp.so won’t show up until after Guac is
successfully built with RDP included.

You can test xfreerdp by simply trying to run it. You’ll need a Windows RDP Server listening
somewhere. If “man xfreerdp” doesn’t work you can get to the man page here: https://linux.die.net/man/1/xfreerdp

I built xfreerdp stable v1.1 on Fedora 23.

Here are all the dependecies I installed:
yum -y install gcc cmake openssl-devel libX11-devel libXext-devel libXinerama-devel libXcursor-devel
libXi-devel libXdamage-devel libXv-devel libxkbfile-devel alsa-lib-devel cups-devel ffmpeg-devel
glib2-devel

I ran autoreconf, configure, and make as a regular user then did make install and ldconfig
as the root user.

I’ve built this numerous times following the below instructions and on occasion run into
the need to fixup the /etc/ld.so.conf file.
https://github.com/FreeRDP/FreeRDP/wiki/Compilation

I would try cleaning everything up, guac included, and trying a fresh start.

Regards,
Jeff



On 6/8/17, 10:43 AM, "xylems" <alexdu@udel.edu> wrote:

    Hi guys,
    
    Thanks for the help on this.. I would like to say i was running free-rdp
    2.0.0..
    
    I went ahead and removed the freerdp-devel version i had installed and
    followed the instructions in compiling and installing release 1.1 
    
    When i run which xfreerdp it comes back with /usr/local/bin/xfreerdp
    
    Seems to be installed properly. In ever used this before so i am not sure
    what else to check.
    
    the file you wanted me to run ldd on /usr/local/lib/libguac-client-rdp.so
    doesnt exist. I am assuming that it is because i have not installed the guac
    server yet as i wanted to make sure the RDP was found in the configure
    stage.
    
    After running ldconfig it is still not finding rdp.
    
    I did try to add the lines you mentioned to /etc/ld.so.conf i am not
    familiar with this file, however i attempted the following inputs:
    
    include ld.so.conf.d/*.conf
    include /usr/local/lib64
    include /usr/local/lib
    include /usr/local/lib/freerdp
    
    
    and 
    
    include ld.so.conf.d/*.conf
    /usr/local/lib64
    /usr/local/lib
    /usr/local/lib/freerdp
    
    Ran ldconfig after each edit and still nothing.
    
    Any suggestions?
    
    
    
    
    --
    View this message in context: http://apache-guacamole-incubating-users.2363388.n4.nabble.com/RDP-Library-not-being-found-tp1083p1093.html
    Sent from the Apache Guacamole (incubating) - Users mailing list archive at Nabble.com.
    

Mime
View raw message