guacamole-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kees Louwen <Kees.Lou...@vancis.nl>
Subject RE: status support TS gateway connections to RDP
Date Fri, 23 Jun 2017 13:12:55 GMT

Hello,

Thanks for the response. As a non-developer it becomes quickly unclear ..;-) ..sorry about
that. I tried to create a patched freerdp version but without luck.

The patch described in guacamole-40 is on FreeRDP  and requires to re-compile FreeRDP, correct?

I tried to compile FreeRDP with the commit in step 1 of guacamole-40, but I am stuck before
I even can apply step 2 as described in guacamole-40. What I did thus far is:


1.       Installed clean centos 7 image

2.       Installed guacamole server (guacd) following: http://guacamole.incubator.apache.org/doc/gug/installing-guacamole.html#building-guacamole-server
with the 9.13 code and freedrp-devel package provided via repo.

3.       Tested: rdp protocol is supported, however without the gateway function;

4.       git clone https://github.com/FreeRDP/FreeRDP.git

5.       git fetch origin 0746d8c14cc8cca7b66bdea31fa6a00cbd509095

6.       git reset --hard FETCH_HEAD

7.       followed compile freerdp instructions: https://github.com/FreeRDP/FreeRDP/wiki/Compilation

8.       did a rebuild of guacamole server as in step 2;

9.       restart of guacd server;

10.   tested: guacd message: support for protocol “rdp” is not installed;

The freerdp compile seem to break rdp protocol. I also tried to first install and compile
FreeRDP on the clean centos 7 image and then build guacamole server, but with the same results.

Any clues or tips? Many thanks.

(note: in 9.13 the guacamole proxy  parameter in the connection configuration seems to be
mandatory and required. I received in the guacamole client log the message: ….connection
refused…. when this proxy parameter wasn’t set. Took me some time to sort that one out.
Hopefully this info might help other users or even a check can be build in the client?)

Thanks for the impressive tool and support.

Regards, Kees

From: Mike Jumper [mailto:mike.jumper@guac-dev.org]
Sent: woensdag 21 juni 2017 18:28
To: user@guacamole.incubator.apache.org
Subject: Re: status support TS gateway connections to RDP

On Wed, Jun 21, 2017 at 3:42 AM, kees Louwen <Kees.Louwen@vancis.nl<mailto:Kees.Louwen@vancis.nl>>
wrote:
Hello,

What is the status and are the requirements to use the TS gateway RDP
options provided in guacamole version 9.13?

0.9.13*

Keep in mind there is no 0.9.13 release yet. You are building the latest code from git. The
version numbers have been bumped in preparation for a release, but that release has not actually
been made yet, and more testing remains to be done.

I am testing version 9.13 in a docker setup, especially the TS Gateway
functionality. Based on the provided dockerfiles the guacamole client and
server are build including freerdp version 1.02. The UI, database, etc show
the required gateway fields. However, when I trace the connection I don't
see any attempts to connect to the specified TS Gateway via port 443.

I have read jira issue guacamole-40 which describes the implementation and
seems to specify I need a patched freerdp version. Any guidance on how to
solve or install this is much appreciated.

Was there anything specifically about the instructions on GUACAMOLE-40 for patching FreeRDP
which was unclear?

- Mike

Mime
View raw message