guacamole-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Евгений Н. Жуков <eugene.zhu...@gmail.com>
Subject Re: EXT: FreeRDP lib version
Date Fri, 12 May 2017 18:00:52 GMT
Hi! I'm running Centos 6.9 or 7 and with FreeRDP from centos
repositories, and always getting error message when I tried to connect
to Hyper-V VM. "Installed version of FreeRDP lacks support for the
preconnection PDU. The specified preconnection BLOB and/or ID will be
ignored".
Which distro or FreeRDP I should use to enable Hyper-V VM connection
and compile guacd with no error or tricks?

2017-05-12 20:42 GMT+03:00 McRoy, Jeffrey (GE Healthcare)
<Jeffrey.McRoy@ge.com>:
> Hi Jerome,
>
> FreeRDP Stable 1.0 or 1.1
>
> https://github.com/FreeRDP/FreeRDP/tree/stable-1.1
> https://github.com/FreeRDP/FreeRDP/wiki/Compilation
>
> If after building, installing, and running ldconfig you have an issue with
> Guac finding the FreeRDP libraries, try this:
> Run ldd on the /usr/local/lib/libguac-client-rdp.so, and it should have some
> libraries that are not found, look for those files, and then add them into
> /etc/ld.so.conf.
> I had to add these:
> /usr/local/lib64
> /usr/local/lib
> /usr/local/lib/freerdp
>
> Then run ldconfig, should work after that.
>
> Regards
> Jeff
>
>
> From: Jerome Charlot - PYGRAM <j.charlot@pygram.com>
> Reply-To: "user@guacamole.incubator.apache.org"
> <user@guacamole.incubator.apache.org>
> Date: Tuesday, May 9, 2017 at 10:55 AM
> To: "'user@guacamole.incubator.apache.org'"
> <user@guacamole.incubator.apache.org>
> Subject: EXT: FreeRDP lib version
>
> Hi,
>
>
>
> I’m trying to build guacamole server (guacd) from source, what is the best
> version of freerdp library to use ?
>
> Is it the ca1cec6 ? Or do you have a more recent/compatible version ?
>
>
>
> Thanks.
>
>
>
> Regards,
>
> Jérôme CHARLOT



-- 
Евгений Н. Жуков
+79534155676, (83145)94800
ICQ: 52108310 skype: xrt_nn

Mime
View raw message